标签:
Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.
Input Specification:
Each input file contains one test case. Each case is given in the following format:
N name[1] ID[1] grade[1] name[2] ID[2] grade[2] ... ... name[N] ID[N] grade[N] grade1 grade2
where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade‘s interval. It is guaranteed that all the grades are distinct.
Output Specification:
For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student‘s name and ID, separated by one space. If there is no student‘s grade in that interval, output "NONE" instead.
Sample Input 1:4 Tom CS000001 59 Joe Math990112 89 Mike CS991301 100 Mary EE990830 95 60 100Sample Output 1:
Mike CS991301 Mary EE990830 Joe Math990112Sample Input 2:
2 Jean AA980920 60 Ann CS01 80 90 95Sample Output 2:
NONE
#pragma warning(disable:4996)
#include <stdio.h>
#include <string>
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
struct Stu
{
char name[11];
char id[11];
int grade;
};
vector<Stu> s,s1;
bool cmp(Stu a,Stu b) {
return a.grade > b.grade;
}
int main(void) {
int n;
cin >> n;
for (int i = 0; i < n; i++) {
Stu temp;
scanf("%s %s %d", temp.name, temp.id, &temp.grade);
s.push_back(temp);
}
int low, high;
cin >> low >> high;
for (int i = 0; i < n; i++) {
if (s[i].grade >= low&&s[i].grade <= high) {
s1.push_back(s[i]);
}
}
if (s1.size() == 0) {
cout << "NONE";
return 0;
}
sort(s1.begin(), s1.end(), cmp);
for (int i = 0; i < s1.size(); i++) {
printf("%s %s\n", s1[i].name, s1[i].id);
}
return 0;
}
标签:
原文地址:http://www.cnblogs.com/zzandliz/p/5023263.html