标签:
reverse 方法很好用
Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.
Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is an integer, and Next is the position of the next node.
Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:00100 6 4 00000 4 99999 00100 1 12309 68237 6 -1 33218 3 00000 99999 5 68237 12309 2 33218Sample Output:
00000 4 33218 33218 3 12309 12309 2 00100 00100 1 99999 99999 5 68237 68237 6 -1
#include <stdio.h>
#include <iostream>
#include <vector>
#include <algorithm>
#pragma warning(disable:4996)
using namespace std;
struct Node {
int adddress;
int value;
int next;
};
vector<Node> list;
int val[100001] = { 0 }, nex[100001] = { 0 };
int main(void) {
int first_addr, n, k;
cin >> first_addr >> n >> k;
if (first_addr == -1) //首地址为-1.直接输出
{
printf("-1\n");
return 0;
}
for (int i = 0; i < n; i++) {
int temp_addr;
cin >> temp_addr;
cin >> val[temp_addr] >> nex[temp_addr];
}
int addr = first_addr;
while (1) {
Node node_temp;
node_temp.adddress = addr;
node_temp.value = val[addr];
node_temp.next = nex[addr];
addr = nex[addr];
list.push_back(node_temp);
if (addr == -1)
break;
}
while (k > list.size()) {
reverse(list.begin(), list.end());
k -= list.size();
}
/*reverse(list.begin(), list.begin() + k);*/
int loop = list.size() / k, i;
for (i = 0; i<loop; ++i)
reverse(list.begin() + i*k, list.begin() + (i + 1)*k);
for (int i = 0; i < list.size()-1; i++) {
list[i].next = list[i + 1].adddress;
}
list[list.size() - 1].next = -1;
for (int i = 0; i < list.size(); i++) {
if (list[i].next != -1)
printf("%05d %d %05d\n", list[i].adddress, list[i].value, list[i].next);
else
printf("%05d %d %d\n", list[i].adddress, list[i].value, list[i].next);
}
return 0;
}
1074. Reversing Linked List (25)
标签:
原文地址:http://www.cnblogs.com/zzandliz/p/5023241.html