标签:
反转二叉树就是左右节点互换
层遍历使用队列实现
中序遍历递归实现
The following is from Max Howell @twitter:
Google: 90% of our engineers use the software you wrote (Homebrew), but you can‘t invert a binary tree on a whiteboard so fuck off.
Now it‘s your turn to prove that YOU CAN invert a binary tree!
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node from 0 to N-1, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.
Output Specification:
For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.
Sample Input:8 1 - - - 0 - 2 7 - - - - 5 - 4 6Sample Output:
3 7 2 6 4 0 5 1 6 5 7 4 3 2 0 1
#include <iostream>
#include <queue>
using namespace std;
int n;
int lfchild[10] = { -1 };
int richild[10] = { -1 };
queue<int> tree;
int cnt = 0;
void Inorder(int a) {
if (lfchild[a] != -1)
Inorder(lfchild[a]);
cout << a;
cnt++;
if (cnt < n)
cout << " ";
if (richild[a] != -1)
Inorder(richild[a]);
}
int main(void) {
for (int i = 0; i < 10; i++) {
lfchild[i] = -1;
richild[i] = -1;
}
int mark[10] = { 0 };
cin >> n;
for (int i = 0; i < n; i++) {
char l, r;
cin >> l >> r;
if (l != ‘-‘) {
richild[i] = l - ‘0‘;
mark[l - ‘0‘]++;
}
if (r != ‘-‘) {
lfchild[i] = r - ‘0‘;
mark[r - ‘0‘]++;
}
}
int root = 0;
for (int i = 0; i < n; i++) {
if (mark[i] == 0) {
root = i;
break;
}
}
tree.push(root);
while (tree.size()>0)
{
if (lfchild[tree.front()] != -1) {
tree.push(lfchild[tree.front()]);
}
if (richild[tree.front()] != -1) {
tree.push(richild[tree.front()]);
}
cout << tree.front();
tree.pop();
if (tree.size() != 0)
cout << " ";
}
cout << endl;
Inorder(root);
return 0;
}
1102. Invert a Binary Tree (25)
标签:
原文地址:http://www.cnblogs.com/zzandliz/p/5023353.html