码迷,mamicode.com
首页 > 其他好文 > 详细

Poj1488--TEX Quotes(有坑点 . 水模拟)

时间:2015-12-06 20:59:31      阅读:236      评论:0      收藏:0      [点我收藏+]

标签:

TEX Quotes
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 9676   Accepted: 5075

Description

TEX is a typesetting language developed by Donald Knuth. It takes source text together with a few typesetting instructions and produces, one hopes, a beautiful document. Beautiful documents use double-left-quote and double-right-quote to delimit quotations, rather than the mundane " which is what is provided by most keyboards. Keyboards typically do not have an oriented double-quote, but they do have a left-single-quote ` and a right-single-quote ‘. Check your keyboard now to locate the left-single-quote key ` (sometimes called the "backquote key") and the right-single-quote key ‘ (sometimes called the "apostrophe" or just "quote"). Be careful not to confuse the left-single-quote ` with the "backslash" key \. TEX lets the user type two left-single-quotes `` to create a left-double-quote and two right-single-quotes ‘‘ to create a right-double-quote. Most typists, however, are accustomed to delimiting their quotations with the un-oriented double-quote ". 

If the source contained 
"To be or not to be," quoth the bard, "that is the question." 
then the typeset document produced by TEX would not contain the desired form: "To be or not to be," quoth the bard, "that is the question." In order to produce the desired form, the source file must contain the sequence: 
``To be or not to be,‘‘ quoth the bard, ``that is the question.‘‘ 
You are to write a program which converts text containing double-quote (") characters into text that is identical except that double-quotes have been replaced by the two-character sequences required by TEX for delimiting quotations with oriented double-quotes. The double-quote (") characters should be replaced appropriately by either `` if the " opens a quotation and by ‘‘ if the " closes a quotation. Notice that the question of nested quotations does not arise: The first " must be replaced by ``, the next by ‘‘, the next by ``, the next by ‘‘, the next by ``, the next by ‘‘, and so on. 

Input

Input will consist of several lines of text containing an even number of double-quote (") characters. Input is ended with an end-of-file character.

Output

The text must be output exactly as it was input except that: 

  • the first " in each pair is replaced by two ` characters: `` and 
  • the second " in each pair is replaced by two ‘ characters: ‘‘. 

Sample Input

"To be or not to be," quoth the Bard, "that
is the question".
The programming contestant replied: "I must disagree.
To `C‘ or not to `C‘, that is The Question!"

Sample Output

``To be or not to be,‘‘ quoth the Bard, ``that
is the question‘‘.
The programming contestant replied: ``I must disagree.
To `C‘ or not to `C‘, that is The Question!‘‘

Source

 
单个字符进行判断ac. 注意字符串结束输入标志,  char c; while((c = getchar())!=EOF){}
知识点:
    puts("abc");输出字符串 
    putchar("a");输出字符
    gets();输入字符串
    getchar();输入字符
#include <cstdio>
#include <iostream>
using namespace std;
int main(){
    char s;
    int sum = 0;
    while((s = getchar())!=EOF){
        if(s =="){
            ++sum;
            if(sum&1)
                printf("``");
            else
                printf("\‘\‘");
        }
        else
            putchar(s);
    }
    return 0;
} 

 

Poj1488--TEX Quotes(有坑点 . 水模拟)

标签:

原文地址:http://www.cnblogs.com/fengshun/p/5024218.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!