码迷,mamicode.com
首页 > 其他好文 > 详细

POJ1014(多重背包)

时间:2015-12-07 00:12:40      阅读:203      评论:0      收藏:0      [点我收藏+]

标签:

Dividing
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 65044   Accepted: 16884

Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000. 
The last line of the input file will be "0 0 0 0 0 0"; do not process this line.

Output

For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can‘t be divided.". 
Output a blank line after each test case.

Sample Input

1 0 1 2 0 0 
1 0 0 0 1 1 
0 0 0 0 0 0 

Sample Output

Collection #1:
Can‘t be divided.

Collection #2:
Can be divided.

Source

 
题目倒是不难,挺久没认真搞算法了,多重背包写了半小时。。。贴个代码备忘
/*
ID: LinKArftc
PROG: 1014.cpp
LANG: C++
*/

#include <map>
#include <set>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <cstdio>
#include <string>
#include <bitset>
#include <utility>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define eps 1e-8
#define randin srand((unsigned int)time(NULL))
#define input freopen("input.txt","r",stdin)
#define debug(s) cout << "s = " << s << endl;
#define outstars cout << "*************" << endl;
const double PI = acos(-1.0);
const int inf = 0x3f3f3f3f;
const int INF = 0x7fffffff;
typedef long long ll;

const int maxn = 200000;
int dp[maxn];
int cnt[10];
int n, m;

void pack01(int c, int v) {
    for (int i = m; i >= c; i --) {
        if (dp[i] < dp[i-c] + v) dp[i] = dp[i-c] + v;
    }
}

void packall(int c, int v) {
    for (int i = c; i <= m; i ++) {
        if (dp[i] < dp[i-c] + v) dp[i] = dp[i-c] + v;
    }
}

void packmult(int c, int v, int n) {
    if (c * n >= m) {
        packall(c, v);
        return ;
    }
    int k = 1;
    while (k <= n) {
        pack01(k * c, k * v);
        n = n - k;
        k *= 2;
    }
    pack01(n * c, n * v);
}

int main() {
    //input;
    int _t = 1;
    int tot;
    while (~scanf("%d %d %d %d %d %d", &cnt[0], &cnt[1], &cnt[2], &cnt[3], &cnt[4], &cnt[5])) {
        if (cnt[0] == 0 && cnt[1] == 0 && cnt[2] == 0 && cnt[3] == 0 && cnt[4] == 0 && cnt[5] == 0) break;
        memset(dp, 0, sizeof(dp));
        printf("Collection #%d:\n", _t ++);
        tot = cnt[0] * 1 + cnt[1] * 2 + cnt[2] * 3 + cnt[3] * 4 + cnt[4] * 5 + cnt[5] * 6;
        if (tot % 2) {
            printf("Can‘t be divided.\n\n");
            continue;
        }
        m = tot / 2;
        for (int i = 0; i < 6; i ++) {
            if (cnt[i]) packmult(i + 1, i + 1, cnt[i]);
        }
        if (m == dp[m]) printf("Can be divided.\n\n");
        else printf("Can‘t be divided.\n\n");
    }

    return 0;
}

 

POJ1014(多重背包)

标签:

原文地址:http://www.cnblogs.com/LinKArftc/p/5024723.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!