码迷,mamicode.com
首页 > 其他好文 > 详细

1050. String Subtraction (20)【字符串处理】——PAT (Advanced Level) Practise

时间:2015-12-07 00:40:03      阅读:114      评论:0      收藏:0      [点我收藏+]

标签:

题目信息

1050. String Subtraction (20)

时间限制10 ms
内存限制65536 kB
代码长度限制16000 B

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 10^4. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.

Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.

解题思路

排除s2中字符输出即可

AC代码

#include <cstdio>
#include <cstring>
char s[10005], aim[10005];

int main()
{
    gets(s);
    gets(aim);
    int len = strlen(s);
    for (int i = 0; i < len; ++i){
        if (NULL == strchr(aim, s[i])){
            putchar(s[i]);
        }
    }
    return 0;
}

1050. String Subtraction (20)【字符串处理】——PAT (Advanced Level) Practise

标签:

原文地址:http://blog.csdn.net/xianyun2009/article/details/50198525

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!