码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1003

时间:2015-12-07 17:56:42      阅读:183      评论:0      收藏:0      [点我收藏+]

标签:

1003. Emergency (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

 

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4

解析:该题的意思如下:在某个城市的消防队在接到另外一个城市的请求救援之后,以最快的速度赶到该城市实施救援,并且在沿路带上尽量多的人手,input提供的就是城市之间的map(map的edge就是两个城市之间的距离),注意事项就是最短路径可能不止一条,我们需要计算具有最多救援队的一条路线———也就是Dijkstra算法小的改动。

Codes:
/*************************************************************************
    > File Name: 1003.cpp
    > Author: 
    > Mail: 
    > Created Time: 2015年12月07日 星期一 14时04分15秒
 ************************************************************************/
#include <iostream>
#include <fstream>
#include <algorithm>
#include <vector>
#include <cstring>

using namespace std;

const int CITYNUM = 500;
const int INF = 0x7fffffff;

int city[CITYNUM];            //记录各个城市的团队数
int road[CITYNUM][CITYNUM]={0};
bool visited[CITYNUM]={false};
int minLen[CITYNUM]={0};    //从源城市到达index城市的最短路径值
int sum[CITYNUM]={0};        //从源城市到达index城市,所能召集的最大团队数
int same[CITYNUM]={0};        //从源城市到达index城市,具有相同最短的路径个数

void Dij(int source,int dest,int n){        //dijkstra算法
    int i,t,mm,next;
    int count = 0;
    int cur = source;
    sum[cur]=city[cur];
    same[cur]=1;
    while(count< n-1){
        visited[cur]=true;
        mm=INF;
        for(i=0;i<n;i++){
            if(visited[i])continue;
            if(road[cur][i]){
                t = minLen[cur] + road[cur][i];
                if(t < minLen[i] || minLen[i]==0){
                    minLen[i]=t;
                    same[i]=same[cur];    
                    sum[i]=sum[cur]+city[i];
                }else if(t == minLen[i]){
                    same[i]+=same[cur];
                    if(sum[cur]+city[i] > sum[i])
                        sum[i]=sum[cur]+city[i];
                }
            }
            if(minLen[i] < mm && minLen[i]!=0){
                mm = minLen[i];
                next = i;
            }
        }
        minLen[cur] = mm;
        if(next == dest)break;
        cur = next;
        count++;
    }
    return;
}

int main()
{
    int n,m,sc,dc;
    cin>>n>>m>>sc>>dc;
    int i;
    for(i=0;i<n;i++)cin>>city[i];
    int c1,c2;
    for(i=0;i<m;i++){
        cin>>c1>>c2;
        cin>>road[c1][c2];
        road[c2][c1]=road[c1][c2];
    }
    if(sc==dc){                            //若所在地就是目的地 则直接输出结果
        cout<<1<< <<city[sc]<<endl;
        return 0;
    }
    Dij(sc,dc,n);
    cout<<same[dc]<< <<sum[dc]<<endl;
    return 0;
}

本来自己写了一个,发现比较繁琐,所以这里贴上http://blog.csdn.net/tiantangrenjian/article/details/19434417的解法,需要注意的是,团队数需要DP,也就是说每次迭代后需要将团队数确定为最短路径的最大值,也就是sum的迭代。

DFS算法:以后再更新。

 

 

PAT 1003

标签:

原文地址:http://www.cnblogs.com/RookieCoder/p/5026318.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!