码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4815 2013长春现场赛C题

时间:2014-07-21 14:03:54      阅读:233      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   strong   os   

C - Little Tiger vs. Deep Monkey
Time Limit:1000MS     Memory Limit:65535KB     64bit IO Format:%I64d & %I64u

Description

A crowd of little animals is visiting a mysterious laboratory ? The Deep Lab of SYSU. 

“Are you surprised by the STS (speech to speech) technology of Microsoft Research and the cat face recognition project of Google and academia? Are you curious about what technology is behind those fantastic demos?” asks the director of the Deep Lab. “Deep learning, deep learning!” Little Tiger raises his hand briskly. “Yes, clever boy, that’s deep learning (深度学习/深度神经网络)”, says the director. “However, they are only ‘a piece of cake’. I won’t tell you a top secret that our lab has invented a Deep Monkey (深猴) with more advanced technology. And that guy is as smart as human!” 

“Nani ?!” Little Tiger doubts about that as he is the smartest kid in his kindergarten; even so, he is not as smart as human, “how can a monkey be smarter than me? I will challenge him.” 

To verify their research achievement, the researchers of the Deep Lab are going to host an intelligence test for Little Tiger and Deep Monkey. 

The test is composed of N binary choice questions. And different questions may have different scores according to their difficulties. One can get the corresponding score for a question if he chooses the correct answer; otherwise, he gets nothing. The overall score is counted as the sum of scores one gets from each question. The one with a larger overall score wins; tie happens when they get the same score. 

Little Tiger assumes that Deep Monkey will choose the answer randomly as he doesn’t believe the monkey is smart. Now, Little Tiger is wondering “what score should I get at least so that I will not lose in the contest with probability of at least P? ”. As little tiger is a really smart guy, he can evaluate the answer quickly. 

You, Deep Monkey, can you work it out? Show your power!?/div>
 

Input

The first line of input contains a single integer T (1 ≤ T ≤ 10) indicating the number of test cases. Then T test cases follow. 

Each test case is composed of two lines. The first line has two numbers N and P separated by a blank. N is an integer, satisfying 1 ≤ N ≤ 40. P is a floating number with at most 3 digits after the decimal point, and is in the range of [0, 1]. The second line has N numbers separated by blanks, which are the scores of each question. The score of each questions is an integer and in the range of [1, 1000]?/div>
 

Output

For each test case, output only a single line with the answer.
 

Sample Input

1 3 0.5 1 2 3
 

Sample Output

3

这题逗逼了,刚开始大帝告诉我题意可能我理解错了,然后就用二进制枚举了!然后然后……然后就浪费了一个多小时一直WA,后面大帝发觉我理解错了之后,他又敲了背包才过……唉……发现题意真的是有点难理解了。到现在题意和解法还都是半知半懂的。

正确的解法是:总的情况是:1<<n,然后可组合的次数除以总的情况>=p的最小分数是正确答案。

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
long long dp[40005];
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n,i,j,sum=0,a[45];
        double p;
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        cin>>n>>p;
        for(i=0;i<n;i++)
            scanf("%d",a+i),sum+=a[i];
        sort(a,a+n);
        for(i=0;i<n;i++)
            for(j=sum;j>=a[i];j--)
                dp[j]+=dp[j-a[i]];
        long long sum1=1LL<<n,sum2=0;
        for(i=0;i<=sum;i++)
        {
            sum2+=dp[i];
            if((double)sum2/(double)sum1>=p)
            {
                printf("%d\n",i);
                break;
            }
        }
    }
    return 0;
}


HDU 4815 2013长春现场赛C题,布布扣,bubuko.com

HDU 4815 2013长春现场赛C题

标签:des   style   http   color   strong   os   

原文地址:http://blog.csdn.net/u011466175/article/details/38014871

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!