码迷,mamicode.com
首页 > 其他好文 > 详细

NYOJ 1049 Climbing Worm

时间:2014-07-21 14:10:55      阅读:195      评论:0      收藏:0      [点我收藏+]

标签:des   style   java   color   strong   os   

Climbing Worm

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12116    Accepted Submission(s): 8149


Problem Description
An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We‘ll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we‘ll assume the worm makes it out.
 

Input
There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.
 

Output
Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.
 

Sample Input
10 2 1 20 3 1 0 0 0
 

Sample Output
17 19
 



#include<stdio.h>
int main()
{
	int n,u,d;
	while(scanf("%d %d %d",&n,&u,&d),n)
	{
		int t;
		t=(n-u)/(u-d);
		if(t*(u-d)<(n-u)) t++;
		t*=2;
		t++;
		printf("%d\n",t);
	}
	return 0;
}



NYOJ 1049 Climbing Worm,布布扣,bubuko.com

NYOJ 1049 Climbing Worm

标签:des   style   java   color   strong   os   

原文地址:http://blog.csdn.net/qq_16767427/article/details/38014233

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!