码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ:5591

时间:2015-12-09 17:10:38      阅读:150      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
ZYB played a game named NumberBomb with his classmates in hiking:a host keeps a number in [1,N] in mind,then 
players guess a number in turns,the player who exactly guesses X loses,or the host will tell all the players that
the number now is bigger or smaller than X.After that,the range players can guess will decrease.The range is [1,N] at first,each player should guess in the legal range.

Now if only two players are play the game,and both of two players know the X,if two persons all use the best strategy,and the first player guesses first.You are asked to find the number of X that the second player
will win when X is in [1,N].
 

 

Input
In the first line there is the number of testcases T.

For each teatcase:

the first line there is one number N.

1T100000,1N10000000
 

 

Output
For each testcase,print the ans.
 

 

Sample Input
1 3
 

 

Sample Output
1
 
 

#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
int T,N,ans1=1,ans2=0;
cin>>T;
while (T--)
{
cin>>N;
if(N%2==1)
cout<<ans1<<endl;
else
cout<<ans2<<endl;
}

}

HDOJ:5591

标签:

原文地址:http://www.cnblogs.com/xiangrutt/p/5032979.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!