码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1000

时间:2015-12-14 18:21:57      阅读:123      评论:0      收藏:0      [点我收藏+]

标签:

杭电第一题

Input

Each line will contain two integers A and B. Process to end of file.

Output

For each case, output A + B in one line.

Sample Input

1 1

Sample Output

2

#include <stdio.h>
int main(void)
{
    int a, b;
    while (scanf("%d %d", &a, &b)==2)
        printf("%d\n",a+b);
    return 0;
}

这是我的答案,和hoj第一题一样。。。看到each line 果断while循环。AC了

不过网上也有这样一种答案:

#include<stdio.h>

int main()
{
 int a,b;
 while(scanf("%d %d",&a,&b)!=EOF)
 {
  printf("%d\n",a+b);
 }
 return 0;
}

一看到EOF,又去查字典了,原来最后一句话是程序进行到文件尾的意思。所以还是第二种答案更好。

同时在网上看到了一种说法,就算题目没有说进行到文件尾的时候结束,也默认是这样得加EOF。看来自己还是差太多。

hdu 1000

标签:

原文地址:http://www.cnblogs.com/kugwzk/p/5045592.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!