码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1014

时间:2015-12-16 15:32:55      阅读:158      评论:0      收藏:0      [点我收藏+]

标签:

1014. Waiting in Line (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer[i] will take T[i] minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.

Sample Input
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output
08:07
08:06
08:10
17:00
Sorry

解析:该问题有两种解决的方法,第一种就是完全模拟法,对所有的用户进行便利模拟,计算出用户离开的时间,这里需要注意的是17:00表示用户接受服务的时间,不是离开的时间,也就是说只要在17:00或者之前接受服务都可以,就算该用户的服务时间要一直持续到晚上十点。

Code:
/*************************************************************************
    > File Name: 1014.cpp
    > Author: 
    > Mail: 
    > Created Time: 2015年12月15日 星期二 21时05分54秒
 ************************************************************************/

#include<iostream>
#include<cstring>
#include<queue>
#include<cstdio>
using namespace std;

#define INF 0x6fffffff

// the waiting queue
queue<int> wait[25];
queue<int> qu[25];
// the processing time
int times[1010];
// the length of windows
int timebase[25] = {0}; 
int leavetime[1010];

int main(){
    int n,m,k,q;
    cin>>n>>m>>k>>q;

    int tmptime;
    for(int i=0; i<k; i++){
        cin>>tmptime;
        times[i] = tmptime;
    }

    // simulate the process
    int top = 0;
    int index;
    for(int i = 0; i<2*k; i++){
        int minlen = m;
        // if there is any customer not int the line
        if(top != k){
            for(int j=0; j<n; j++){
                if(minlen > qu[j].size()){
                    minlen = qu[j].size();
                    index = j;
                }
            }
        }

        //find the queue have minimum length
        if(minlen != m){
            qu[index].push(top);
            wait[index].push(times[top]);
            top++;
        }
        // every queue is full or all customer in lines
        else{
            long minwait = INF;
            bool empty = true;
            for(int j=0; j<n; j++){
                if(wait[j].empty()) continue;
                if(minwait > timebase[j]+wait[j].front()){
                    minwait = timebase[j]+wait[j].front();
                    index = j;
                    empty = false;
                }
            }

            if(empty) break;
            timebase[index] += wait[index].front();
            leavetime[qu[index].front()] = timebase[index];
            qu[index].pop();
            wait[index].pop();
        }
    }

    int tmp;
    while(q--){
        cin>>tmp;
        tmp--;

        if(leavetime[tmp]-times[tmp] < 60*9){
            int hour = leavetime[tmp]/60;
            int min = leavetime[tmp]%60;
            printf("%02d:%02d\n",8+hour,min);
        }
        else{
            printf("Sorry\n");
        }
    }

    return 0;
}

还有一种方法后续再写。

 

PAT 1014

标签:

原文地址:http://www.cnblogs.com/RookieCoder/p/5051144.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!