码迷,mamicode.com
首页 > 其他好文 > 详细

(区间dp 或 记忆化搜素 )Brackets -- POJ -- 2955

时间:2015-12-16 18:59:57      阅读:128      评论:0      收藏:0      [点我收藏+]

标签:

http://poj.org/problem?id=2955

 

 

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

 

 

 

#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;

const int INF = 0x3f3f3f3f;
#define N 105

char s[N];
int  dp[N][N];

int main()
{
    while(scanf("%s", s), strcmp(s, "end"))
    {
        int i, j, k, len=strlen(s)-1;

        memset(dp, 0, sizeof(dp));

        for(i=len-1; i>=0; i--)
        {
            for(j=i+1; j<=len; j++)
            {
                dp[i][j] = dp[i+1][j];

                for(k=i+1; k<=j; k++)
                {
                    if((s[i]==( && s[k]==)) || (s[i]==[ && s[k]==]))
                    {
                        if(k==i+1) dp[i][j] = max(dp[i][j], dp[k+1][j]+2);
                        else       dp[i][j] = max(dp[i][j], dp[i+1][k-1]+dp[k+1][j]+2);
                    }
                }
            }
        }

        printf("%d\n", dp[0][len]);
    }
    return 0;
}

 

(区间dp 或 记忆化搜素 )Brackets -- POJ -- 2955

标签:

原文地址:http://www.cnblogs.com/YY56/p/5051617.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!