码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1837

时间:2014-07-21 23:27:52      阅读:235      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   strong   

Balance
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 10307   Accepted: 6377

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm‘s length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
? the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
? the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: ‘-‘ for the left arm and ‘+‘ for the right arm); 
? on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights‘ values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2

Source

Romania OI 2002

AC代码:

#include<iostream>
#include<cstring>
using namespace std;
int a[22],b[22];
long long f[22][15005];       //f[i][j]表示挂了i个砝码,在重量为j的位置有多少种方法
int main(){
    int n,m;
    while(cin>>n>>m){
        memset(f,0,sizeof(f));
        for(int i=1;i<=n;i++)
            cin>>a[i];
        for(int i=1;i<=m;i++)
            cin>>b[i];
        f[0][7500]=1;                   //20*15*25为极限,所以定7500为平衡位置
        for(int i=1;i<=m;i++)
            for(int j=0;j<=15000;j++)
                if(f[i-1][j])
                    for(int k=1;k<=n;k++){
                        f[i][j+b[i]*a[k]]+=f[i-1][j];
                    }
        cout<<f[m][7500]<<endl;          //平衡位置的方法数
    }
    return 0;
}


poj 1837,布布扣,bubuko.com

poj 1837

标签:des   style   http   color   os   strong   

原文地址:http://blog.csdn.net/my_acm/article/details/38020753

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!