标签:
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1024
Max Sum Plus Plus
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21926 Accepted Submission(s): 7342
Problem Description
Now I think you have got an AC in Ignatius.L‘s "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.
Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).
Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).
But I`m lazy, I don‘t want to write a special-judge module, so you don‘t have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^
Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.
Output
Output the maximal summation described above in one line.
Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3
Sample Output
6
8
Hint
Huge input, scanf and dynamic programming is recommended.
Author
JGShining(极光炫影)
题意:输入m,n,然后输入n个数。求最大连续m段和。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
using namespace std;
const int oo = 0x7fffffff;
int a[1000005];
int dp[1000005];
int Max[1000005];
int main()
{
int m,n;
while(~scanf("%d%d", &m, &n))
{
for(int i=1; i<=n; i++)
{
scanf("%d", &a[i]);
Max[i] = 0;
dp[i] = 0;
}
int M;
dp[0] = 0;
Max[0] = 0;
for(int i=1; i<=m; i++)
{
M = -oo;
for(int j=i; j<=n; j++)
{
dp[j] = max(dp[j-1]+a[j], Max[j-1]+a[j]);
Max[j-1] = M;
M = max(dp[j], M);
}
}
printf("%d\n",M);
}
return 0;
}
HDU 1024 Max Sum Plus Plus
标签:
原文地址:http://www.cnblogs.com/mengzhong/p/5058186.html