码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-3280 Equal Sum Partitions

时间:2014-07-22 22:48:13      阅读:218      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   java   color   

http://acm.hdu.edu.cn/showproblem.php?pid=3280

用了简单的枚举。

Equal Sum Partitions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 453    Accepted Submission(s): 337

Problem Description
An equal sum partition of a sequence of numbers is a grouping of the numbers (in the same order as the original sequence) in such a way that each group has the same sum. For example, the sequence: 2 5 1 3 3 7 may be grouped as: (2 5) (1 3 3) (7) to yield an equal sum of 7.
Note: The partition that puts all the numbers in a single group is an equal sum partition with the sum equal to the sum of all the numbers in the sequence.
For this problem, you will write a program that takes as input a sequence of positive integers and returns the smallest sum for an equal sum partition of the sequence.
 
Input
The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. The first line of each data set contains the data set number, followed by a space, followed by a decimal integer M, (1 ≤ M ≤ 10000), giving the total number of integers in the sequence. The remaining line(s) in the dataset consist of the values, 10 per line, separated by a single space. The last line in the dataset may contain less than 10 values.
 
Output
For each data set, generate one line of output with the following values: The data set number as a decimal integer, a space, and the smallest sum for an equal sum partition of the sequence.
 
Sample Input
3
1 6
2 5 1 3 3 7
2 6
1 2 3 4 5 6
3 20
1 1 2 1 1 2 1 1 2 1 1 2 1 1 2 1 1 2 1 1
 
Sample Output
1 7
2 21
3 2
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int a[10005];
int main()
{
    int i,j,t,n,m,sum,cursum,flag ,ans;
    scanf("%d",&t);
    while(t--)
    {
          flag=0;
        memset(a,0,sizeof(a));
        scanf("%d%d",&n,&m);
        for(i=0;i<m;i++)
          scanf("%d",&a[i]);
            for(i=0;i<m;i++)
           {
                 sum=0;
            for(j=0;j<=i;j++)
                  sum+=a[j];
               cursum=0;
             while(j<m)
              {
                cursum+=a[j];
               if(cursum>sum)
                   break;
               else if(cursum==sum)
                   {
                        j++;
                        if(j==m)
                        {
                           printf("%d %d\n",n,sum);
                           flag=1;
                        }
                        cursum=0;
                   }
                 else
                     j++;
                 if(flag)
                   break;
             }

            if(flag)
                break;
           }
          if(i==m)
           printf("%d %d\n",n,sum);
     }
    return 0;
}
/*
3
1 6
2 5 1 3 3 7
2 6
1 2 3 4 5 6
3 20
1 1 2 1 1 2 1 1 2 1
1 2 1 1 2 1 1 2 1 1
*/

 

HDU-3280 Equal Sum Partitions,布布扣,bubuko.com

HDU-3280 Equal Sum Partitions

标签:des   style   blog   http   java   color   

原文地址:http://www.cnblogs.com/cancangood/p/3859488.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!