码迷,mamicode.com
首页 > 其他好文 > 详细

I can do it!(贪心)

时间:2015-12-20 15:50:31      阅读:124      评论:0      收藏:0      [点我收藏+]

标签:

I can do it!

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others) Total Submission(s): 1010    Accepted Submission(s): 471

Problem Description
Given n elements, which have two properties, say Property A and Property B. For convenience, we use two integers Ai and Bi to measure the two properties.  Your task is, to partition the element into two sets, say Set A and Set B , which minimizes the value of max(x∈Set A) {Ax}+max(y∈Set B) {By}. See sample test cases for further details.
 

 

Input
There are multiple test cases, the first line of input contains an integer denoting the number of test cases. For each test case, the first line contains an integer N, indicates the number of elements. (1 <= N <= 100000) For the next N lines, every line contains two integers Ai and Bi indicate the Property A and Property B of the ith element. (0 <= Ai, Bi <= 1000000000)
 

 

Output
For each test cases, output the minimum value.
 

 

Sample Input
1 3 1 100 2 100 3 1
 

 

Sample Output
Case 1: 3
 

 

Author
HyperHexagon
 

题解:题意好难理解啊,好像是给你一些元素,这些元素有两个性质,把这两个性质分成两个集合,然后找A几何中最大值加上B集合中最大值的最小化值;可以用贪心来找。。。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
#define mem(x,y) memset(x,y,sizeof(x))
#define T_T while(T--)
#define SI(x) scanf("%d",&x)
#define SL(x) scanf("%lld",&x)
typedef long long LL;
const int INF=0x3f3f3f3f;
const int MAXN=100010;
struct Node{
	int a,b;
	friend bool operator < (Node x,Node y){
		return x.a>y.a;
	}
};
Node dt[MAXN];
int main(){
	int T,N,kase=0;
	SI(T);
	T_T{
		SI(N);
		for(int i=0;i<N;i++)SI(dt[i].a),SI(dt[i].b);
		sort(dt,dt+N);
		int A,B=0,ans=INF;
		for(int i=0;i<N;i++){
			ans=min(ans,B+dt[i].a);
			B=max(dt[i].b,B);
		}
		printf("Case %d: %d\n",++kase,ans);
	}
	return 0;
}

  

I can do it!(贪心)

标签:

原文地址:http://www.cnblogs.com/handsomecui/p/5060965.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!