码迷,mamicode.com
首页 > 其他好文 > 详细

Ants(思维)

时间:2015-12-20 15:57:22      阅读:164      评论:0      收藏:0      [点我收藏+]

标签:

Ants
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 12893   Accepted: 5637

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207
题解:水题,就是一个木棒在水里,蚂蚁在这个木棒上可以右走,也可以左走,1cm/s,问最小最大多长时间都掉到水里;
代码:
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int MAXN=1000010;
int a[MAXN];
int main(){
	int T,l,n,x,mx;
	scanf("%d",&T);
	while(T--){
		scanf("%d%d",&l,&n);
		mx=-1;
		for(int i=0;i<n;i++){
			scanf("%d",&x);
			mx=max(mx,x);
			mx=max(mx,l-x);
			a[i]=min(x,l-x);
		}
		printf("%d %d\n",*max_element(a,a+n),mx);
	}
	return 0;
}

  

Ants(思维)

标签:

原文地址:http://www.cnblogs.com/handsomecui/p/5060989.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!