码迷,mamicode.com
首页 > 其他好文 > 详细

zoj3819Average Score

时间:2015-12-24 00:17:02      阅读:248      评论:0      收藏:0      [点我收藏+]

标签:

Average Score

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Bob is a freshman in Marjar University. He is clever and diligent. However, he is not good at math, especially in Mathematical Analysis.

After a mid-term exam, Bob was anxious about his grade. He went to the professor asking about the result of the exam. The professor said:

"Too bad! You made me so disappointed."

"Hummm... I am giving lessons to two classes. If you were in the other class, the average scores of both classes will increase."

Now, you are given the scores of all students in the two classes, except for the Bob‘s. Please calculate the possible range of Bob‘s score. All scores shall be integers within [0, 100].

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (2 <= N <= 50) and M (1 <= M <= 50) indicating the number of students in Bob‘s class and the number of students in the other class respectively.

The next line contains N - 1 integers A1A2, .., AN-1 representing the scores of other students in Bob‘s class.

The last line contains M integers B1B2, .., BM representing the scores of students in the other class.

Output

For each test case, output two integers representing the minimal possible score and the maximal possible score of Bob.

It is guaranteed that the solution always exists.

Sample Input

2
4 3
5 5 5
4 4 3
6 5
5 5 4 5 3
1 3 2 2 1

Sample Output

4 4
2 4
题意:有两个班的同学,其中bob在第一班,然后输入每个班同学的成绩,如果bob属于二班的时候,两个班的平均分都会提高,求bob得分的上下限
分析:bob成绩大于二班平均分,小于一班其他的平均分。我用double存总分,在求最后结果时纠结了好久,上限<平均分,如果平均分是整数的话就是-1,不是整数直接强制转换,下限>平均分,不管平均分怎样都直接+1;
其实后来又搜了一下别人写的,发现直接用int就ok,而且还方便,便于求那个平均分是不是整数,直接取模
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int main()
{
    int t;
    scanf("%d", &t);
    for(int k = 1; k <= t; k++)
    {
        int n,m,score;
        double scoren = 0,scorem = 0;
        scanf("%d%d", &n, &m);
        for(int i = 1; i <= n - 1; i++)
        {
            scanf("%d", &score);
            scoren += score;
        }
        for(int i = 1; i <= m; i++)
        {
            scanf("%d", &score);
            scorem += score;
        }
        printf("%d ",(int) ( scorem / m + 1) );
        if(scoren / (n - 1) == (int) scoren / (n - 1))  //这里一直不确定是不是可行,
        printf("%d\n",(int) ( scoren / (n -1) - 1));
        else
            printf("%d\n", (int) (scoren / (n - 1) ));
    }

    return 0;
}

 

zoj3819Average Score

标签:

原文地址:http://www.cnblogs.com/zhaopAC/p/5071705.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!