标签:
1066. Root of AVL Tree (25)
时间限制100 ms
内存限制65536 kB
代码长度限制16000 B
An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.
Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<=20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print ythe root of the resulting AVL tree in one line.
Sample Input 1:
5
88 70 61 96 120
Sample Output 1:
70
Sample Input 2:
7
88 70 61 96 120 90 65
Sample Output 2:
88
建个avl树,没啥技巧
#include <cstdio>
#include <algorithm>
using namespace std;
struct node{
node *left, *right;
int v, w;
node(int value, node* l, node* r) : v(value), left(l), right(r), w(0) {}
};
node *nil = new node(0, NULL, NULL);
node *head = nil;
void leftrotate(node *&head){
node *t = head->right;
head->right = t->left;
t->left = head;
head = t;
head->left->w = max(head->left->right->w, head->left->left->w) + 1;
head->w = max(head->right->w, head->left->w) + 1;
}
void rightrotate(node *&head){
node *t = head->left;
head->left = t->right;
t->right = head;
head = t;
head->right->w = max(head->right->right->w, head->right->left->w) + 1;
head->w = max(head->right->w, head->left->w) + 1;
}
void insert(node *&head, int v){
if (head == nil){
head = new node(v, nil, nil);
}else if (v > head->v){
insert(head->right, v);
if (2 == head->right->w - head->left->w){
if (v > head->right->v){
leftrotate(head);
}else{
rightrotate(head->right);
leftrotate(head);
}
}
}else{
insert(head->left, v);
if (2 == head->left->w - head->right->w){
if (v <= head->left->v){
rightrotate(head);
}else{
leftrotate(head->left);
rightrotate(head);
}
}
}
head->w = max(head->left->w, head->right->w) + 1;
}
int main()
{
int n, a;
scanf("%d", &n);
while (n--){
scanf("%d", &a);
insert(head, a);
}
printf("%d\n", head->v);
return 0;
}
个人游戏推广:
《10云方》与方块来次消除大战!
1066. Root of AVL Tree (25)【AVL树】——PAT (Advanced Level) Practise
标签:
原文地址:http://blog.csdn.net/xianyun2009/article/details/50410882