码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1711 Number Sequence(字符串匹配)

时间:2014-07-22 22:34:32      阅读:194      评论:0      收藏:0      [点我收藏+]

标签:des   style   java   color   os   strong   

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10571    Accepted Submission(s): 4814


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 


 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 


 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 


 

Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 


 

Sample Output
6 -1
 


 

 

#include<iostream>
#include<cstdio>
using namespace std;
const int maxn1=1000010;
const int maxn2=10010;
int n,m;
int a[maxn1];
int b[maxn2];
int next[maxn2];
int main()
{
 int kmp (int *a,int *b,int *next);
 int t,i;
 cin>>t;
 while(t--)
 {
  cin>>n>>m;
  for(i=0;i<n;i++)
  {scanf("%d",&a[i]);}
  for(i=0;i<m;i++)
  {scanf("%d",&b[i]);}
  int ans=kmp(a,b,next);
  cout<<ans<<endl;
 }
 return 0;
}


//此函数用来求匹配串s串的next数组
void getnext (int *s,int *next)
{
    next[0]=next[1]=0;
    for (int i=1;i<m;i++)//m为匹配串s的长度
 {
        int j=next[i];
        while (j&&s[i]!=s[j])
            j=next[j];
        next[i+1]=s[i]==s[j]?j+1:0;
    }
}
//此函数用来求匹配位置的值的函数,匹配不成功返回值-1
int kmp (int *a,int *b,int *next)
{
    getnext (b,next);/////////
    int j=0;
    for (int i=0;i<n;i++)
 {/////n为串1的长度
        while (j&&a[i]!=b[j])
            j=next[j];
        if (a[i]==b[j])
            j++;
        if (j==m)//m为串2的长度
            return i-m+2;
    }
    return -1;
}


 

 

HDU 1711 Number Sequence(字符串匹配),布布扣,bubuko.com

HDU 1711 Number Sequence(字符串匹配)

标签:des   style   java   color   os   strong   

原文地址:http://blog.csdn.net/hot_summer_days/article/details/38044785

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!