码迷,mamicode.com
首页 > 其他好文 > 详细

Identity Card(水题)

时间:2015-12-28 23:19:05      阅读:306      评论:0      收藏:0      [点我收藏+]

标签:

Identity Card

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2696    Accepted Submission(s): 1048

Problem Description
Do you own an ID card?You must have a identity card number in your family‘s Household Register. From the ID card you can get specific personal information of everyone. The number has 18 bits,the first 17 bits contain special specially meanings:the first 6 bits represent the region you come from,then comes the next 8 bits which stand for your birthday.What do other 4 bits represent?You can Baidu or Google it. Here is the codes which represent the region you are in. 技术分享  However,in your card,maybe only 33 appears,0000 is replaced by other numbers. Here is Samuel‘s ID number 331004198910120036 can you tell where he is from?The first 2 numbers tell that he is from Zhengjiang Province,number 19891012 is his birthday date (yy/mm/dd).
 

 

Input
Input will contain 2 parts: A number n in the first line,n here means there is n test cases. For each of the test cases,there is a string of the ID card number.
 

 

Output
Based on the table output where he is from and when is his birthday. The format you can refer to the Sample Output.
 

 

Sample Input
1 330000198910120036
 

 

Sample Output
He/She is from Zhejiang,and his/her birthday is on 10,12,1989 based on the table.
 

 

Author
Samuel
 

水题:给你身份证号让你找信息;注意string不能用scanf输入。。。

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<map>
#include<string>
using namespace std;
const int INF=0x3f3f3f3f;
const double PI=acos(-1.0);
#define mem(x,y) memset(x,y,sizeof(x))
#define SI(x) scanf("%d",&x)
#define SL(x) scanf("%lld",&x)
#define PI(x) printf("%d",x)
#define PL(x) printf("%lld",x)
#define P_ printf(" ")
#define T_T while(T--)
typedef long long LL;
map<string,string>mp;
int main(){
	int T,y,m,d;
	string s;
	SI(T);
	mp["33"]="Zhejiang";
	mp["11"]="Beijing";
	mp["71"]="Taiwan";
	mp["81"]="Hong Kong";
	mp["82"]="Macao";
	mp["54"]="Tibet";
	mp["21"]="Liaoning";
	mp["31"]="Shanghai";
	T_T{
		//scanf("%s",s.c_str());
		cin>>s;
		printf("He/She is from %s,and his/her birthday is on %s,%s,%s based on the table.\n",mp[s.substr(0,2)].c_str(),s.substr(10,2).c_str(),s.substr(12,2).c_str(),s.substr(6,4).c_str());
		//cout<<"He/She is from "<<mp[s.substr(0,2)]<<",and his/her birthday is on "<<s.substr(10,2)<<","<<s.substr(12,2)<<","<<s.substr(6,4)<<" based on the table."<<endl;
	}
	return 0;
}

  

 

Identity Card(水题)

标签:

原文地址:http://www.cnblogs.com/handsomecui/p/5084243.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!