码迷,mamicode.com
首页 > 其他好文 > 详细

排名(水题)

时间:2015-12-29 22:41:18      阅读:222      评论:0      收藏:0      [点我收藏+]

标签:

排名

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 19177    Accepted Submission(s): 7033

Problem Description
今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑  每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的  考生,并将他们的成绩按降序打印。 
 

 

Input
测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N  < 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;以下N行,每行给出一  名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号  (题目号由1到M)。  当读入的考生人数为0时,输入结束,该场考试不予处理。 
 

 

Output
对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高  到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考  号的升序输出。 
 

 

Sample Input
4 5 25 10 10 12 13 15 CS004 3 5 1 3 CS003 5 2 4 1 3 5 CS002 2 1 2 CS001 3 2 3 5 1 2 40 10 30 CS001 1 2 2 3 20 10 10 10 CS000000000000000001 0 CS000000000000000002 2 1 2 0
 

 

Sample Output
3 CS003 60 CS001 37 CS004 37 0 1 CS000000000000000002 20
Hint
Huge input, scanf is recommended.
 

题解:水题;

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<map>
#include<string>
using namespace std;
const int INF=0x3f3f3f3f;
const double PI=acos(-1.0);
#define mem(x,y) memset(x,y,sizeof(x))
#define SI(x) scanf("%d",&x)
#define SL(x) scanf("%lld",&x)
#define PI(x) printf("%d",x)
#define PL(x) printf("%lld",x)
#define P_ printf(" ")
#define T_T while(T--)
typedef long long LL;
int score[15];
int ans;
int G;
struct Node{
	char s[25];
	int len;
	int m[15];
	int tot;
	Node init(){
		tot=0;
		int len;
		scanf("%s",s);
		scanf("%d",&len);
		for(int i=0;i<len;i++)
			scanf("%d",&m[i]),tot+=score[m[i]];
			if(tot>=G)ans++;
	}
	friend int operator < (Node a,Node b){
		if(a.tot!=b.tot)return a.tot>b.tot;
		else return strcmp(a.s,b.s)<0;
	}
};
Node m[1010];
int main(){
	int N,M,len;
	while(SI(N),N){
		SI(M);SI(G);
		for(int i=1;i<=M;i++)SI(score[i]);
		ans=0;
		for(int i=0;i<N;i++){
			m[i].init();
		}
		sort(m,m+N);
		printf("%d\n",ans);
		for(int i=0;i<N;i++){
			if(m[i].tot>=G)
				printf("%s %d\n",m[i].s,m[i].tot);
			else break;
		}
	}
	return 0;
}

  

 

排名(水题)

标签:

原文地址:http://www.cnblogs.com/handsomecui/p/5087042.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!