码迷,mamicode.com
首页 > 其他好文 > 详细

HDU计算机学院大学生程序设计竞赛(2015’12)The Country List

时间:2015-12-29 22:41:17      阅读:236      评论:0      收藏:0      [点我收藏+]

标签:

The Country List

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2598    Accepted Submission(s): 615

Problem Description
As the 2010 World Expo hosted by Shanghai is coming, CC is very honorable to be a volunteer of such an international pageant. His job is to guide the foreign visitors. Although he has a strong desire to be an excellent volunteer, the lack of English makes him annoyed for a long time. 
Some countries’ names look so similar that he can’t distinguish them. Such as: Albania and Algeria. If two countries’ names have the same length and there are more than 2 same letters in the same position of each word, CC cannot distinguish them. For example: Albania and AlgerIa have the same length 7, and their first, second, sixth and seventh letters are same. So CC can’t distinguish them.
Now he has received a name list of countries, please tell him how many words he cannot distinguish. Note that comparisons between letters are case-insensitive.
Input
There are multiple test cases.
Each case begins with an integer n (0 < n < 100) indicating the number of countries in the list.
The next n lines each contain a country’s name consisted by ‘a’ ~ ‘z’ or ‘A’ ~ ‘Z’.
Length of each word will not exceed 20.
You can assume that no name will show up twice in the list.
Output
For each case, output the number of hard names in CC’s list.
Sample Input
3
Denmark
GERMANY
China
4
Aaaa
aBaa
cBaa
cBad
 
Sample Output
2
4
查找单词是否相同(相同的条件 长度相同,且有三个相同位置以上的有相同字母)
用set存一存就好了
#include<stdio.h>
//#include<bits/stdc++.h>
#include<string.h>
#include<iostream>
#include<math.h>
#include<sstream>
#include<set>
#include<queue>
#include<map>
#include<vector>
#include<algorithm>
#include<limits.h>
#define inf 0x3fffffff
#define INF 0x3f3f3f3f
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define LL long long
#define ULL unsigned long long
using namespace std;
int n;
string ss[100];
set<string> q;
int main ()
{
    while(cin>>n)
    {
        int i,j;
        for(i=0; i<n; i++)
        {
            cin>>ss[i];
        }
        for(i=0; i<n; i++)
        {
            for(j=0; j<n; j++)
            {
                int sum=0;
                if(i==j) continue;
                if(ss[i].length()==ss[j].length())
                {
                    for(int z=0; z<ss[i].length(); z++)
                    {
                        if(ss[i][z]==ss[j][z]||abs(ss[i][z]-ss[j][z])==32)
                        {
                            sum++;
                        }
                    }
                    if(sum>2)
                    {
                  //      cout<<ss[i]<<" "<<ss[j]<<endl;
                        q.insert(ss[j]);
                    }
                }

            }
        }
        cout<<q.size()<<endl;
        q.clear();
    }
    return 0;
}

  

 
 

HDU计算机学院大学生程序设计竞赛(2015’12)The Country List

标签:

原文地址:http://www.cnblogs.com/yinghualuowu/p/5087064.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!