码迷,mamicode.com
首页 > 其他好文 > 详细

装箱问题

时间:2014-07-22 22:50:32      阅读:209      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   java   color   

 
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null‘‘ line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 
需要注意的是一些计算技巧!
1)1*1的空间的话可以在最后通过t1=cout*36-f*36-e*25-d*16-c*9-b*4;然后再比较a与t1的大小。
2)向上取整:a=(t+8)/9;
#include<cstdio>
using namespace std;
int main()
{
    int a,b,c,d,e,f;
    int u[4]={0,5,3,1};
    int cout,t1,t2;
    while(1)
    {
        cout=0;
        t1=0;t2=0;
        scanf("%d%d%d%d%d%d",&a,&b,&c,&d,&e,&f);
        if(a==0&&b==0&&c==0&&d==0&&e==0&&f==0)
            break;
        cout=f+e+d+(c+3)/4;
        t2=5*d+u[c%4];

        if(b>t2)
        {
            cout+=(b-t2+8)/9;
        }

        t1=36*cout-36*f-25*e-16*d-9*c-4*b;
        if(a>t1)
            cout+=(a-t1+35)/36;
        printf("%d\n",cout);
    }
}

  


装箱问题,布布扣,bubuko.com

装箱问题

标签:des   style   blog   http   java   color   

原文地址:http://www.cnblogs.com/angledamon/p/3861194.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!