码迷,mamicode.com
首页 > 其他好文 > 详细

UVA - 297Quadtrees(四分图)

时间:2016-01-03 22:32:23      阅读:292      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

 Status

Description

技术分享
 

A quadtree is a representation format used to encode images. The fundamental idea behind the quadtree is that any image can be split into four quadrants. Each quadrant may again be split in four sub quadrants, etc. In the quadtree, the image is represented by a parent node, while the four quadrants are represented by four child nodes, in a predetermined order.

 

Of course, if the whole image is a single color, it can be represented by a quadtree consisting of a single node. In general, a quadrant needs only to be subdivided if it consists of pixels of different colors. As a result, the quadtree need not be of uniform depth.

 

A modern computer artist works with black-and-white images of 技术分享 units, for a total of 1024 pixels per image. One of the operations he performs is adding two images together, to form a new image. In the resulting image a pixel is black if it was black in at least one of the component images, otherwise it is white.

 

This particular artist believes in what he calls the preferred fullness: for an image to be interesting (i.e. to sell for big bucks) the most important property is the number of filled (black) pixels in the image. So, before adding two images together, he would like to know how many pixels will be black in the resulting image. Your job is to write a program that, given the quadtree representation of two images, calculates the number of pixels that are black in the image, which is the result of adding the two images together.

 

In the figure, the first example is shown (from top to bottom) as image, quadtree, pre-order string (defined below) and number of pixels. The quadrant numbering is shown at the top of the figure.

 

技术分享

Input Specification

The first line of input specifies the number of test cases (N) your program has to process.

The input for each test case is two strings, each string on its own line. The string is the pre-order representation of a quadtree, in which the letter ‘p‘ indicates a parent node, the letter ‘f‘ (full) a black quadrant and the letter ‘e‘ (empty) a white quadrant. It is guaranteed that each string represents a valid quadtree, while the depth of the tree is not more than 5 (because each pixel has only one color).

 

Output Specification

For each test case, print on one line the text ‘There are X black pixels.‘, where X is the number of black pixels in the resulting image.

 

Example Input

 

3
ppeeefpffeefe
pefepeefe
peeef
peefe
peeef
peepefefe

 

Example Output

 

There are 640 black pixels.
There are 512 black pixels.
There are 384 black pixels.
题解:
给你两个像素,让求两个像素合并起来的黑色像素的大小;
由于给的是四分图的先序遍历,那么这个图也就可以画出来了,于是可以边建图,边画图,如果遇到黑色像素f就画图,如果遇到p就递归建图;
其中x,y表示坐上点的位置,len代表当前图的面积;
代码:
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
using namespace std;
#define SI(x) scanf("%d",&x)
#define mem(x,y) memset(x,y,sizeof(x)) 
#define PI(x) printf("%d",x)
#define P_ printf(" ")
const int INF=0x3f3f3f3f;
typedef long long LL;
const int MAXN=40;
int buf[MAXN][MAXN];
char s[2020];
int cnt;
void draw(int &k,int x,int y,int len){
	char ch=s[k++];
	if(ch==‘p‘){
		draw(k,x,y,len/2);
		draw(k,x,y+len/2,len/2);
		draw(k,x+len/2,y,len/2);
		draw(k,x+len/2,y+len/2,len/2);
	}
	else if(ch==‘f‘){
		for(int i=x;i<x+len;i++)
			for(int j=y;j<y+len;j++)
				if(!buf[i][j])buf[i][j]=1,cnt++;
	}
}
int main(){
	int T;
	SI(T);
	while(T--){
		cnt=0;
		mem(buf,0);
		for(int i=0;i<2;i++){
			mem(s,0);
			scanf("%s",s);
			int k=0;
			draw(k,0,0,32);
		}
		printf("There are %d black pixels.\n",cnt);
	}
	return 0;
}

  

UVA - 297Quadtrees(四分图)

标签:

原文地址:http://www.cnblogs.com/handsomecui/p/5097274.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!