码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2503 Babelfish

时间:2014-07-23 00:13:48      阅读:305      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   os   strong   width   

表示刚刚做出来 就发现不能提交了 好悲催= =

伤心难过痛哭流涕%>_<%

Babelfish
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 31630   Accepted: 13613

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.



#include <iostream>
#include <string>
#include <map>
#include <stdio.h>
#include <cstring>
using namespace std;
int main()
{
	map <string ,bool >appear;
	map <string ,string>printf;
	char s[40],sa[20],sb[20];
	string f;
	string english;
    while (gets(s))
	{
		if (s[0]=='\0')
			break;
		int len1;
		int len=strlen(s);
		for(len1=0;len1<len;len1++)
			if(s[len1]==' ')
				break;
		int i;
		for(i=0;i<len1;i++)
			sa[i]=s[i];
		sa[len1]='\0';
		int k=0;
		for(i=len1+1;i<len;i++)
			sb[k++]=s[i];
		sb[k]='\0';
		english=sa;
		f=sb;
		appear[f]=true;
		printf[f]=english;
	}
	string s1;
	while(cin>>s1)
	{
		if(appear[s1]==true)
			cout<<printf[s1]<<endl;
		else
			cout<<"eh"<<endl;
	}
    return 0;
}

/*
dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay
*/




POJ 2503 Babelfish,布布扣,bubuko.com

POJ 2503 Babelfish

标签:des   style   color   os   strong   width   

原文地址:http://blog.csdn.net/sunshumin/article/details/38046393

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!