码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1065 I Think I Need a Houseboat 【数学递推】

时间:2014-07-23 13:13:06      阅读:321      评论:0      收藏:0      [点我收藏+]

标签:hdu1065

I Think I Need a Houseboat

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9530    Accepted Submission(s): 2733


Problem Description
bubuko.com,布布扣

Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion.

After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.)

bubuko.com,布布扣
 

Input
The first line of input will be a positive integer indicating how many data sets will be included (N).

Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given.
 

Output
For each data set, a single line of output should appear. This line should take the form of:

“Property N: This property will begin eroding in year Z.”

Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer.

After the last data set, this should print out “END OF OUTPUT.”

Notes:

1. No property will appear exactly on the semicircle boundary: it will either be inside or outside.

2. This problem will be judged automatically. Your answer must match exactly, including the capitalization, punctuation, and white-space. This includes the periods at the ends of the lines.

3. All locations are given in miles.
 

Sample Input
2 1.0 1.0 25.0 0.0
 

Sample Output
Property 1: This property will begin eroding in year 1. Property 2: This property will begin eroding in year 20. END OF OUTPUT.

题意:给定一个从原点开始且中心在原点的半圆,每天以50mile^2的速度向外扩充,给你一个点,求第几天扩充的半圆能覆盖到它。

题解:这题最先开始想到的思路是模拟,但是考虑到模拟太耗时间又觉得这题应该能找到规律,然后就拿着笔在演草纸上画了出来,规律是pi/2*(r[n]^2 - r[n-1]^2)=100; r[1]^2 = 100 / pi; r[n]表示第n天半圆覆盖的半径,这明显是一个等差数列,得到r[n]^2 = 100*n/pi;然后就该直接用公式了~

#include <stdio.h>

int main()
{
    int t;
    double x, y;
    scanf("%d", &t);
    for(int i = 1; i <= t; ++i){
        scanf("%lf%lf", &x, &y);
        printf("Property %d: This property will begin eroding in year %d.\n",
            i, int((x*x + y*y) * 3.1415926 / 100 + 1));
    }
    printf("END OF OUTPUT.\n");
    return 0;
}


HDU1065 I Think I Need a Houseboat 【数学递推】

标签:hdu1065

原文地址:http://blog.csdn.net/chang_mu/article/details/38059813

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!