码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1219 AC Me

时间:2014-07-23 15:01:56      阅读:213      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   java   color   os   

AC Me

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11719    Accepted Submission(s): 5210


Problem Description
Ignatius is doing his homework now. The teacher gives him some articles and asks him to tell how many times each letter appears.

It‘s really easy, isn‘t it? So come on and AC ME.
 

 

Input
Each article consists of just one line, and all the letters are in lowercase. You just have to count the number of each letter, so do not pay attention to other characters. The length of article is at most 100000. Process to the end of file.

Note: the problem has multi-cases, and you may use "while(gets(buf)){...}" to process to the end of file.
 

 

Output
For each article, you have to tell how many times each letter appears. The output format is like "X:N". 

Output a blank line after each test case. More details in sample output.
 

 

Sample Input
hello, this is my first acm contest! work hard for hdu acm.
 

 

Sample Output
a:1 b:0 c:2 d:0 e:2 f:1 g:0 h:2 i:3 j:0 k:0 l:2 m:2 n:1 o:2 p:0 q:0 r:1 s:4 t:4 u:0 v:0 w:0 x:0 y:1 z:0 a:2 b:0 c:1 d:2 e:0 f:1 g:0 h:2 i:0 j:0 k:1 l:0 m:1 n:0 o:2 p:0 q:0 r:3 s:0 t:0 u:1 v:0 w:1 x:0 y:0 z:0
 

 

 

 

          很简单的一题吧。

 

贴代码:

 

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

char str[100005];

int main()
{
    int n1;
    int s[30];
    while(gets(str))
    {
        n1 = strlen(str);
        memset(s, 0, sizeof(s));
        for(int ii = 0; ii<n1; ii++)
        {
            s[str[ii]-a]++;
        }
        printf("a:%d\nb:%d\nc:%d\nd:%d\ne:%d\nf:%d\ng:%d\nh:%d\ni:%d\nj:%d\nk:%d\nl:%d\nm:%d\nn:%d\no:%d\np:%d\nq:%d\nr:%d\ns:%d\nt:%d\nu:%d\nv:%d\nw:%d\nx:%d\ny:%d\nz:%d\n", s[0],s[1],s[2],s[3],s[4],s[5],s[6],s[7],s[8],s[9],s[10],
               s[11],s[12],s[13],s[14],s[15],s[16],s[17],s[18],s[19],s[20],s[21],s[22],s[23],s[24],s[25]);
        printf("\n");
    }
}

hdu 1219 AC Me,布布扣,bubuko.com

hdu 1219 AC Me

标签:des   style   blog   java   color   os   

原文地址:http://www.cnblogs.com/fengxmx/p/3862716.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!