码迷,mamicode.com
首页 > 其他好文 > 详细

【CODEVS1219】骑士游历

时间:2016-01-17 16:08:25      阅读:134      评论:0      收藏:0      [点我收藏+]

标签:

  • 题目描述 Description

设有一个n*m的棋盘(2≤n≤50,2≤m≤50),如下图,在棋盘上有一个中国象棋马。

规定:

1)马只能走日字

2)马只能向右跳

问给定起点x1,y1和终点x2,y2,求出马从x1,y1出发到x2,y2的合法路径条数。

技术分享
  • 输入描述 Input Description

第一行2个整数n和m

第二行4个整数x1,y1,x2,y2

  • 输出描述 Output Description

输出方案数

  • 样例输入 Sample Input

30 30

1 15 3 15

  • 样例输出 Sample Output

2

  • 数据范围及提示 Data Size & Hint

2<=n,m<=50

 

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
long long a[100][100];
int main(){
    memset(a,0,sizeof(a));
    int n,m,x1,x2,y1,y2;
    scanf("%d%d%d%d%d%d",&n,&m,&x1,&y1,&x2,&y2);
    a[x1][y1]=1;
    for (int i=x1+1;i<=n;i++)
        for (int j=1;j<=m;j++)
        { a[i][j]=a[i-1][j+2];
        if (j-2>=0) a[i][j]+=a[i-1][j-2];
        if (i-2>=0) a[i][j]+=a[i-2][j+1]+a[i-2][j-1];
        }
    printf("%lld",a[x2][y2]);
    return 0;
}

 

【CODEVS1219】骑士游历

标签:

原文地址:http://www.cnblogs.com/liumengyue/p/5137299.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!