码迷,mamicode.com
首页 > 其他好文 > 详细

HDU4864:Task(贪心)

时间:2014-07-23 16:36:41      阅读:208      评论:0      收藏:0      [点我收藏+]

标签:贪心   hdu   

Problem Description
Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes this task, they will get (500*xi+2*yi) dollars.
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task can only be completed by one machine.
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.
 

Input
The input contains several test cases. 
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000).
The following N lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the maximum time the machine can work.yi is the level of the machine.
The following M lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the time we need to complete the task.yi is the level of the task.
 

Output
For each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get.
 

Sample Input
1 2 100 3 100 2 100 1
 

Sample Output
1 50004
 


题意:n台机器,m个任务,每台机器和任务都有两个值,机器的两个值都大于任务的两个值,这台机器才能完成这个任务,每台机器只能完成一个任务,问最大收益
思路:贪心,标记好暴力即可

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

struct node
{
    int x,y;
} s1[100005],s2[100005];

int cmp(node a,node b)
{
    if(a.x == b.x)
        return a.y>b.y;
    return a.x>b.x;
}

int main()
{
    int n,m,i,j,cnt;
    __int64 sum;
    while(~scanf("%d%d",&n,&m))
    {
        for(i = 0; i<n; i++)
            scanf("%d%d",&s1[i].x,&s1[i].y);
        for(i = 0; i<m; i++)
            scanf("%d%d",&s2[i].x,&s2[i].y);
        sort(s1,s1+n,cmp);
        sort(s2,s2+m,cmp);
        cnt = sum = 0;
        int c[105] = {0};
        for(i = 0,j = 0; i<m; i++)
        {
            while(j<n && s1[j].x>=s2[i].x)
            {
                c[s1[j].y]++;
                j++;
            }
            for(int k = s2[i].y; k<=100; k++)
            {
                if(c[k])
                {
                    c[k]--;
                    sum+=(s2[i].x*500+s2[i].y*2);
                    cnt++;
                    break;
                }
            }
        }
        printf("%d %I64d\n",cnt,sum);
    }
}


HDU4864:Task(贪心)

标签:贪心   hdu   

原文地址:http://blog.csdn.net/libin56842/article/details/38066205

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!