码迷,mamicode.com
首页 > 其他好文 > 详细

usaco-Section 3.1-Stamps

时间:2016-01-24 19:44:40      阅读:244      评论:0      收藏:0      [点我收藏+]

标签:

Stamps

Given a set of N stamp values (e.g., {1 cent, 3 cents}) and an upper limit K to the number of stamps that can fit on an envelope, calculate the largest unbroken list of postages from 1 cent to M cents that can be created.

For example, consider stamps whose values are limited to 1 cent and 3 cents; you can use at most 5 stamps. It‘s easy to see how to assemble postage of 1 through 5 cents (just use that many 1 cent stamps), and successive values aren‘t much harder:

  • 6 = 3 + 3
  • 7 = 3 + 3 + 1
  • 8 = 3 + 3 + 1 + 1
  • 9 = 3 + 3 + 3
  • 10 = 3 + 3 + 3 + 1
  • 11 = 3 + 3 + 3 + 1 + 1
  • 12 = 3 + 3 + 3 + 3
  • 13 = 3 + 3 + 3 + 3 + 1.

However, there is no way to make 14 cents of postage with 5 or fewer stamps of value 1 and 3 cents. Thus, for this set of two stamp values and a limit of K=5, the answer is M=13.

The most difficult test case for this problem has a time limit of 3 seconds.

PROGRAM NAME: stamps

INPUT FORMAT

Line 1: Two integers K and N. K (1 <= K <= 200) is the total number of stamps that can be used. N (1 <= N <= 50) is the number of stamp values.
Lines 2..end: N integers, 15 per line, listing all of the N stamp values, each of which will be at most 10000.

SAMPLE INPUT (file stamps.in)

5 2
1 3

OUTPUT FORMAT

Line 1: One integer, the number of contiguous postage values starting at 1 cent that can be formed using no more than K stamps from the set.

SAMPLE OUTPUT (file stamps.out)

13

一道简单的dp,思想就是记忆化。

代码如下:
/*
ID: yizeng21
PROB: stamps
LANG: C++
*/
#include<stdio.h>
#include<string.h>
using namespace std;
int dp[2000005];
int maxx;
int max(int i,int j){
    return i>j?i:j;
}
int min(int i,int j){
    return i<j?i:j;
}
int a[10000];
int main(){
    freopen("stamps.in","r",stdin);
    freopen("stamps.out","w",stdout);
    int m,n;
    scanf("%d%d",&m,&n);
    for(int i=1;i<=n;i++){
        scanf("%d",&a[i]);
        maxx=max(maxx,a[i]);
    }
    memset(dp,10,sizeof(dp));
    
    dp[0]=0;
    for(int j=1;j<=n;j++)
        for(int i=a[j];i<=maxx*m;i++){
            dp[i]=min(dp[i],dp[i-a[j]]+1);
        }
    int tot=0;
    while(dp[tot]<=m)tot++;
    printf("%d\n",tot-1);
}

 

usaco-Section 3.1-Stamps

标签:

原文地址:http://www.cnblogs.com/buffms/p/5155671.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!