码迷,mamicode.com
首页 > 其他好文 > 详细

usaco-Section 3.1-Contact

时间:2016-01-24 19:43:09      阅读:310      评论:0      收藏:0      [点我收藏+]

标签:

Contact
IOI‘98

The cows have developed a new interest in scanning the universe outside their farm with radiotelescopes. Recently, they noticed a very curious microwave pulsing emission sent right from the centre of the galaxy. They wish to know if the emission is transmitted by some extraterrestrial form of intelligent life or if it is nothing but the usual heartbeat of the stars.

Help the cows to find the Truth by providing a tool to analyze bit patterns in the files they record. They are seeking bit patterns of length A through Binclusive (1 <= A <= B <= 12) that repeat themselves most often in each day‘s data file. They are looking for the patterns that repeat themselves most often. An input limit tells how many of the most frequent patterns to output.

Pattern occurrences may overlap, and only patterns that occur at least once are taken into account.

PROGRAM NAME: contact

INPUT FORMAT

Line 1: Three space-separated integers: A, B, N; (1 <= N ≤ 50)
Lines 2 and beyond: A sequence of as many as 200,000 characters, all 0 or 1; the characters are presented 80 per line, except potentially the last line.

SAMPLE INPUT (file contact.in)

2 4 10
01010010010001000111101100001010011001111000010010011110010000000

In this example, pattern 100 occurs 12 times, and pattern 1000 occurs 5 times. The most frequent pattern is 00, with 23 occurrences.

OUTPUT FORMAT

Lines that list the N highest frequencies (in descending order of frequency) along with the patterns that occur in those frequencies. Order those patterns by shortest-to-longest and increasing binary number for those of the same frequency. If fewer than N highest frequencies are available, print only those that are.

Print the frequency alone by itself on a line. Then print the actual patterns space separated, six to a line (unless fewer than six remain).

SAMPLE OUTPUT (file contact.out)

23
00
15
01 10
12
100
11
11 000 001
10
010
8
0100
7
0010 1001
6
111 0000
5
011 110 1000
4
0001 0011 1100
 思路很简单,用map存下字母串对应的位置,给它一个新的位置,用一个cost记录出现的次数,最后排序,注意输出格式。
 
代码如下:
/*
ID: yizeng21
PROB: contact
LANG: C++
*/
#include<stdio.h>
#include<string>
#include<iostream>
#include<map>
#include<algorithm>
using namespace std;
struct hh{
    int xiaobiao,spend;
}r[300000];
string where[300000];
bool cmp(hh i,hh j){
    if(i.spend>j.spend)return 1;
    else if(i.spend==j.spend){
        if(where[i.xiaobiao].length()<where[j.xiaobiao].length())return 1;
        else if(where[i.xiaobiao].length()==where[j.xiaobiao].length()){
            int len=where[i.xiaobiao].length();
            int ans1=0,ans2=0;
            for(int w=0;w<len;w++){
                ans1=ans1*2+where[i.xiaobiao][w]-0;
            }
            for(int w=0;w<len;w++){
                ans2=ans2*2+where[j.xiaobiao][w]-0;
            }
            if(ans1>ans2)return 0;
            else return 1;
        }else return 0;
    }else return 0;
}
int cost[300000];
map<string,int>name;
int main(){
    freopen("contact.in","r",stdin);
    freopen("contact.out","w",stdout);
    char str[300000];
    int a,b,c;
    scanf("%d%d%d",&a,&b,&c);
    char q;
    int tot=0;
    int pos=0;
    while(scanf("%c",&q)!=EOF){
        if((q==1)||(q==0)){
            str[++tot]=q;
            string h="";
            for(int i=tot;i>=tot-a+2;i--){
                if(i<=0)break;
                h=str[i]+h;
            }
            for(int i=tot-a+1;i>=tot-b+1;i--){
                if(i<=0)break;
                h=str[i]+h;
                if(name[h]==0){
                    name[h]=++pos;
                    where[pos]=h;
                }
                cost[name[h]]++;
            }
        }
    }
    for(int i=1;i<=pos;i++){
        r[i].xiaobiao=i;
        r[i].spend=cost[i];
    }
    sort(r+1,r+pos+1,cmp);
    int printnum=c;
    int last=1;
    int len=pos;
    int biaoji=0;
    while(printnum!=0){
        int asd=0;
        printnum--;
        pos--;
        printf("%d\n",r[last].spend);
        asd++;
        cout<<where[r[last].xiaobiao];
        for(int i=last+1;;i++){
            if(i>len){
                biaoji=1;
                break;
                
            }
            if(r[i].spend==r[last].spend){
                if(asd%6!=0)cout<<" ";
                cout<<where[r[i].xiaobiao];
                asd++;
                if(asd%6==0)printf("\n");
                last++;
            }else break;
        }
        if(biaoji==1){
            if(asd%6!=0)printf("\n");
            break;
        }
        last++;
        if(asd%6!=0)printf("\n");
        if(pos==0)break;
    }
}

 

usaco-Section 3.1-Contact

标签:

原文地址:http://www.cnblogs.com/buffms/p/5155665.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!