码迷,mamicode.com
首页 > 其他好文 > 详细

UVA - 1476 Error Curves 三分

时间:2016-01-25 01:23:49      阅读:219      评论:0      收藏:0      [点我收藏+]

标签:

                                       Error Curves

Josephina is a clever girl and addicted to Machine Learning recently. She pays much attention to a

method called Linear Discriminant Analysis, which has many interesting properties.
In order to test the algorithm’s e?ciency, she collects many datasets. What’s more, each data is
divided into two parts: training data and test data. She gets the parameters of the model on training
data and test the model on test data.
To her surprise, she ?nds each dataset’s test error curve is just a parabolic curve. A parabolic curve
corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of
the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0.
It’s very easy to calculate the minimal error if there is only one test error curve. However, there
are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to
get the tuned parameters that make the best performance on all datasets. So she should take all error
curves into account, i.e., she has to deal with many quadric functions and make a new error de?nition
to represent the total error. Now, she focuses on the following new function’s minimal which related to
multiple quadric functions.
The new function F(x) is de?ned as follow:
F(x) = max(Si(x)), i = 1. . . n. The domain of x is [0,1000]. Si(x) is a quadric function.
Josephina wonders the minimum of F(x). Unfortunately, it’s too hard for her to solve this problem.
As a super programmer, can you help her?
Input
The input contains multiple test cases. The ?rst line is the number of cases T (T < 100). Each case
begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100),
b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coe?cients of a quadratic function.
Output
For each test case, output the answer in a line. Round to 4 digits after the decimal point.
Sample Input
2
1
2 0 0
2
2 0 0
2 -4 2
Sample Output
0.0000
0.5000

 

题意

  给定n条二次曲线S(x),定义F(x)=max(Si(x)), 求出F(x)在0~1000上的最小值。

题解:

  三分基础题,三分下凸。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;
typedef long long ll;
const int  N = 10000 + 10;
int T,a[N],b[N],c[N],n;
double f(double x) {
    double ans = a[1] * x * x + b[1] * x + c[1];
    for(int i = 1; i <= n; i++) {
        ans = max(ans, a[i] * x * x + b[i] * x + c[i]);
    }
    return ans;
}
double three_search(double l,double r) {
    for(int i = 0 ;i < 100; i++) {
        double mid = l + (r - l) / 3;
        double mid2 = r - (r - l) / 3;
        if(f(mid) > f(mid2)) l = mid;
        else r = mid2;
    }
    return f(l);
}
int main() {
    scanf("%d",&T);
    while(T--) {
        scanf("%d",&n);
        for(int i = 1; i <= n; i++) scanf("%d%d%d",&a[i],&b[i],&c[i]);
        double ans = three_search(0,1000);
        printf("%.4f\n",ans);
    }
    return 0;
}

 

UVA - 1476 Error Curves 三分

标签:

原文地址:http://www.cnblogs.com/zxhl/p/5156349.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!