码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3159 Candies

时间:2014-07-23 22:39:18      阅读:554      评论:0      收藏:0      [点我收藏+]

标签:图论   算法   poj   最短路径   

题目链接:http://poj.org/problem?id=3159


Candies
Time Limit: 1500MS   Memory Limit: 131072K
Total Submissions: 22516   Accepted: 6047

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 throughN. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers AB and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

Hint

32-bit signed integer type is capable of doing all arithmetic.

Source


最短路径的经典题,用堆优化一下就完了。。算做是稍微复习下吧。

#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<queue>
#include<stack>
#include<string>
#include<vector>
#include<set>
#include<map>
#include<bitset>
#include<cstdlib>
#define CLR(A) memset(A,0,sizeof(A))
using namespace std;
struct Node{
    int k,w;
};
bool operator <(const Node &a,const Node &b){return a.w>b.w;}
priority_queue<Node> q;
vector<vector<Node> > g;
bool used[30010]={0};
int main(){
    int n,m;
    Node p;
    while(~scanf("%d%d",&n,&m)){
        g.clear();
        g.resize(n+1);
        CLR(used);
        for(int i=1;i<=m;i++){
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            p.k=b;p.w=c;
            g[a].push_back(p);
        }
        p.k=1;p.w=0;
        q.push(p);
        while(!q.empty()){
            p=q.top();q.pop();
            if(used[p.k]) continue;
            used[p.k]=true;
            if(p.k==n) break;
            Node tmp;
            for(int i=0;i<g[p.k].size();i++){
                tmp.k=g[p.k][i].k;
                if(used[tmp.k]) continue;
                tmp.w=p.w+g[p.k][i].w;
                q.push(tmp);
            }
        }
        printf("%d\n",p.w);
    }
    return 0;
}


poj 3159 Candies

标签:图论   算法   poj   最短路径   

原文地址:http://blog.csdn.net/asdfghjkl1993/article/details/38070803

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!