码迷,mamicode.com
首页 > 其他好文 > 详细

poj3630 Phone List (trie树模板题)

时间:2016-01-26 23:40:06      阅读:398      评论:0      收藏:0      [点我收藏+]

标签:

Phone List
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 26328   Accepted: 7938

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let‘s say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it‘s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob‘s phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES
题意:就是问这些号码中是否存在一串号码是另一串号码的前缀,典型的trie树模板题;
AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int N=100010;
char str[N][10];
int t,n,cnt,trie[N][20],flag,val[N];
void build_checktrie(char*s,int v)
{
    int len=strlen(s),u=0;
    for(int i=0;i<len;i++)
    {
        int num=s[i]-‘0‘;
        if(!trie[u][num])
        {
            for(int j=0;j<=10;j++)
            {
                trie[cnt][j]=0;
            }
            val[cnt]=0;
            trie[u][num]=cnt++;
        }
        else
        {
            if(i==len-1)
            {
                flag=0;
            }
            if(val[trie[u][num]])
            {
                flag=0;
            }
        }
        u=trie[u][num];
    }
    val[u]=v;
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        memset(trie,0,sizeof(trie));
        memset(val,0,sizeof(val));
        cnt=1;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%s",str[i]);
        }
        flag=1;
        for(int i=1;i<=n;i++)
        {
            build_checktrie(str[i],1);
            if(!flag)break;
        }
        if(flag)printf("YES\n");
        else printf("NO\n");

    }
    return 0;
}

 

poj3630 Phone List (trie树模板题)

标签:

原文地址:http://www.cnblogs.com/zhangchengc919/p/5161869.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!