码迷,mamicode.com
首页 > 其他好文 > 详细

POJ3352(连通分量缩点)

时间:2016-01-29 00:01:44      阅读:374      评论:0      收藏:0      [点我收藏+]

标签:

Road Construction
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 10352   Accepted: 5140

Description

It‘s almost summer time, and that means that it‘s almost summer construction time! This year, the good people who are in charge of the roads on the tropical island paradise of Remote Island would like to repair and upgrade the various roads that lead between the various tourist attractions on the island.

The roads themselves are also rather interesting. Due to the strange customs of the island, the roads are arranged so that they never meet at intersections, but rather pass over or under each other using bridges and tunnels. In this way, each road runs between two specific tourist attractions, so that the tourists do not become irreparably lost.

Unfortunately, given the nature of the repairs and upgrades needed on each road, when the construction company works on a particular road, it is unusable in either direction. This could cause a problem if it becomes impossible to travel between two tourist attractions, even if the construction company works on only one road at any particular time.

So, the Road Department of Remote Island has decided to call upon your consulting services to help remedy this problem. It has been decided that new roads will have to be built between the various attractions in such a way that in the final configuration, if any one road is undergoing construction, it would still be possible to travel between any two tourist attractions using the remaining roads. Your task is to find the minimum number of new roads necessary.

Input

The first line of input will consist of positive integers n and r, separated by a space, where 3 ≤ n ≤ 1000 is the number of tourist attractions on the island, and 2 ≤ r ≤ 1000 is the number of roads. The tourist attractions are conveniently labelled from 1 to n. Each of the following r lines will consist of two integers, v and w, separated by a space, indicating that a road exists between the attractions labelled v and w. Note that you may travel in either direction down each road, and any pair of tourist attractions will have at most one road directly between them. Also, you are assured that in the current configuration, it is possible to travel between any two tourist attractions.

Output

One line, consisting of an integer, which gives the minimum number of roads that we need to add.

Sample Input

Sample Input 1
10 12
1 2
1 3
1 4
2 5
2 6
5 6
3 7
3 8
7 8
4 9
4 10
9 10

Sample Input 2
3 3
1 2
2 3
1 3

Sample Output

Output for Sample Input 1
2

Output for Sample Input 2
0
题意:给定结点和边的数目,确定一幅无向图,问至少加几条边使图为双连通的。(双连通:图中任意两个结点都有两条或以上不同的路径)
思路:利用tarjan算法将图中的双连通部分缩为一点,进而得到一棵树。那么(这棵树的叶子结点数目+1)/2 即为答案。
#include"cstdio"
#include"cstring"
using namespace std;
const int MAXN=1005;
int V,E;
bool mp[MAXN][MAXN];//结点不超过1000用邻接矩阵存储 
int index;
int dfn[MAXN],low[MAXN];
int stack[MAXN],top;
int cpnt[MAXN],cnt;
inline int min(int a,int b)
{
    return a > b? b: a;
}
void tarjan(int u,int fa)
{
    stack[top++]=u;
    dfn[u]=low[u]=++index;
    for(int i=1;i<=V;i++)
    {
        if(mp[u][i])
        {
            int v=i;
            if(!dfn[v])
            {
                tarjan(v,u);
                low[u]=min(low[u],low[v]);
            }
            else if(v!=fa)    low[u]=min(low[u],dfn[v]);
        }
    }
    if(low[u]==dfn[u])
    {
        int v;
        cnt++;
        do{
            v=stack[--top];
            cpnt[v]=cnt;
        }while(u!=v);
    }
}
int deg[MAXN];
int seek()
{
    int ans=0;
    for(int i=1;i<=V;i++)
        for(int j=1;j<=V;j++)    
            if(mp[i][j]&&cpnt[i]!=cpnt[j])
            {
                deg[cpnt[i]]++;
                deg[cpnt[j]]++;
            }
        
    for(int i=1;i<=cnt;i++)
        if(deg[i]==2)    ans++;
    return ans;
}
int main()
{
    while(scanf("%d%d",&V,&E)!=EOF)
    {
        memset(mp,false,sizeof(mp));
        memset(dfn,0,sizeof(dfn));
        memset(low,0,sizeof(low));
        top=0;
        cnt=0;
        memset(cpnt,0,sizeof(cpnt));
        memset(deg,0,sizeof(deg));
        for(int i=0;i<E;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            mp[u][v]=mp[v][u]=true;
        }
        tarjan(1,-1);
        int ans=seek();
        printf("%d\n",(ans+1)/2);
    
    }
    return 0;
}

 

POJ3352(连通分量缩点)

标签:

原文地址:http://www.cnblogs.com/program-ccc/p/5167597.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!