码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2952 Counting Sheep

时间:2016-01-30 18:12:36      阅读:197      评论:0      收藏:0      [点我收藏+]

标签:

题目链接

Problem Description
A while ago I had trouble sleeping. I used to lie awake, staring at the ceiling, for hours and hours. Then one day my grandmother suggested I tried counting sheep after I‘d gone to bed. As always when my grandmother suggests things, I decided to try it out. The only problem was, there were no sheep around to be counted when I went to bed.

Creative as I am, that wasn‘t going to stop me. I sat down and wrote a computer program that made a grid of characters, where # represents a sheep, while . is grass (or whatever you like, just not sheep). To make the counting a little more interesting, I also decided I wanted to count flocks of sheep instead of single sheep. Two sheep are in the same flock if they share a common side (up, down, right or left). Also, if sheep A is in the same flock as sheep B, and sheep B is in the same flock as sheep C, then sheeps A and C are in the same flock.

Now, I‘ve got a new problem. Though counting these sheep actually helps me fall asleep, I find that it is extremely boring. To solve this, I‘ve decided I need another computer program that does the counting for me. Then I‘ll be able to just start both these programs before I go to bed, and I‘ll sleep tight until the morning without any disturbances. I need you to write this program for me.
 

 

Input
The first line of input contains a single number T, the number of test cases to follow.

Each test case begins with a line containing two numbers, H and W, the height and width of the sheep grid. Then follows H lines, each containing W characters (either # or .), describing that part of the grid.
 
Output
For each test case, output a line containing a single number, the amount of sheep flock son that grid according to the rules stated in the problem description.
Notes and Constraints
0 < T <= 100
0 < H,W <= 100
 
Sample Input
2 4 4
#.#.
.#.#
#.##
.#.#
3 5
###
.#.
.#.
.#.
###
 
Sample Output
6 3

题解:题目描述什么的一大段废话,直接看输入输出,发现是一个经典的DFS连通块问题。

#include <cstdio>
#include <iostream>
#include <string>
#include <sstream>
#include <cstring>
#include <stack>
#include <queue>
#include <algorithm>
#include <cmath>
#include <map>
#define ms(a) memset(a,0,sizeof(a))
#define msp memset(mp,0,sizeof(mp))
#define msv memset(vis,0,sizeof(vis))
using namespace std;
//#define LOCAL
char mp[120][120];
int n,m;
int ans;
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
void dfs(int x,int y)
{
    for(int i=0;i<4;i++)
    {
        int nx=x+dir[i][0],ny=y+dir[i][1];
        if(nx>=0&&nx<n&&ny>=0&&ny<m)
        {
            if(mp[nx][ny]==#)
            {
                mp[nx][ny]=.;
                dfs(nx,ny);
            }
        }
    }
    return;
}
int main()
{
#ifdef LOCAL
    freopen("in.txt", "r", stdin);
#endif // LOCAL
    //Start
    int N;
    cin>>N;
    while(N--)
    {
        cin>>n>>m;
        msp,ans=0;
        for(int i=0; i<n; i++)cin>>mp[i];
        for(int i=0; i<n; i++)
        for(int j=0; j<m; j++)
        if(mp[i][j]==#)
        {
            mp[i][j]=.;
            ans++;
            dfs(i,j);
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

HDU 2952 Counting Sheep

标签:

原文地址:http://www.cnblogs.com/gpsx/p/5171175.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!