码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2614 Beat(DFS)

时间:2016-02-03 17:24:59      阅读:212      评论:0      收藏:0      [点我收藏+]

标签:

题目链接

Problem Description
Zty is a man that always full of enthusiasm. He wants to solve every kind of difficulty ACM problem in the world. And he has a habit that he does not like to solve
a problem that is easy than problem he had solved. Now yifenfei give him n difficulty problems, and tell him their relative time to solve it after solving the other one.
You should help zty to find a order of solving problems to solve more difficulty problem. 
You may sure zty first solve the problem 0 by costing 0 minute. Zty always choose cost more or equal time’s problem to solve.
 
Input
The input contains multiple test cases.
Each test case include, first one integer n ( 2< n < 15).express the number of problem.
Than n lines, each line include n integer Tij ( 0<=Tij<10), the i’s row and j’s col integer Tij express after solving the problem i, will cost Tij minute to solve the problem j.
 
Output
For each test case output the maximum number of problem zty can solved

Sample Input
3
0 0 0
1 0 1
1 0 0
3
0 2 2
1 0 1
1 1 0
5
0 1 2 3 1
0 0 2 3 1
0 0 0 3 1
0 0 0 0 2
0 0 0 0 0
 
Sample Output
3
2
4
 
Hint
Hint: sample one, as we know zty always solve problem 0 by costing 0 minute. So after solving problem 0, he can choose problem 1 and problem 2, because T01 >=0 and T02>=0. But if zty chooses to solve problem 1, he can not solve problem 2, because T12 < T01. So zty can choose solve the problem 2 second, than solve the problem 1.
 
题解:题目说的是zty做题目有一个奇怪的习惯,不会去做那些花费时间少于已经做过的题目所花时间的题,也就是说不会做更简单的题。在题目中,就是搜索的下一个位置的数字不能比之前的小。zty总是从第一题开始做起。
 
#include <cstdio>
#include <iostream>
#include <string>
#include <cstring>
#include <stack>
#include <queue>
#include <algorithm>
#include <cmath>
#include <map>
using namespace std;
//#define LOCAL
int pro[15][15],maxx,n;
bool vis[15];
void dfs(int p,int las,int cnt)
{
    int flag=0;
    for(int i=1; i<=n; i++)
    {
        if(!vis[i]&&(pro[p][i]>=las))
        {
            vis[i]=1;
            dfs(i,pro[p][i],cnt+1);
            vis[i]=0;
            flag=1;
        }
    }
    if(!flag)if(cnt>maxx)maxx=cnt;
}
int main()
{
#ifdef LOCAL
    freopen("in.txt", "r", stdin);
#endif // LOCAL
    //Start
    while(cin>>n)
    {
        maxx=0;
        memset(pro,0,sizeof pro);
        memset(vis,0,sizeof vis);
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                cin>>pro[i][j];
        vis[1]=1;
        dfs(1,0,1);
        printf("%d\n",maxx);
    }
    return 0;
}

 

HDU 2614 Beat(DFS)

标签:

原文地址:http://www.cnblogs.com/gpsx/p/5180109.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!