码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1083(最大匹配)

时间:2016-02-03 23:30:17      阅读:307      评论:0      收藏:0      [点我收藏+]

标签:

Courses

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5414    Accepted Submission(s): 2600


Problem Description
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
...... 
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you‘ll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:
 

 

Sample Input
2
3 3 3
1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1
 
Sample Output
YES
NO
 
在二分图中两个独立的顶点集合V1,V2。当|V1|<|V2|且最大匹配|M|=|V1|时成为完全匹配。当|V1|=|V2|时称为完美匹配。
比较裸的完全匹配。
#include"cstdio"
#include"cstring"
#include"vector"
using namespace std;
const int MAXN=300;
int P,N;
vector<int> G[MAXN*2+10];
int match[MAXN*2+10];
int vis[MAXN*2+10];
void add_edge(int u,int v)
{
    G[u].push_back(v);
    G[v].push_back(u);
}
bool dfs(int u)
{
    vis[u]=1;
    for(int i=0;i<G[u].size();i++)
    {
        int v=G[u][i],w=match[v];
        if(w<0||(!vis[w]&&dfs(w)))
        {
            match[u]=v;
            match[v]=u;
            return true;            
        }
    }
    return false;
}
int bipartite_matching()
{
    memset(match,-1,sizeof(match));
    int ans=0;
    for(int i=1;i<=P;i++)
    {
        if(match[i]<0)
        {
            memset(vis,0,sizeof(vis));
            if(dfs(i))    ans++;    
        }
    }
    return ans;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        for(int i=0;i<MAXN*2+10;i++)    G[i].clear();
        scanf("%d%d",&P,&N);
        for(int i=1;i<=P;i++)
        {
            int s;
            scanf("%d",&s);
            while(s--)
            {
                int v;
                scanf("%d",&v);
                add_edge(i,v+MAXN);
                add_edge(v+MAXN,i);
            }
        }
        int ans=bipartite_matching();
        if(ans==P)    printf("YES\n");
        else printf("NO\n");
    }
    
    return 0;
}

 

 
 

HDU1083(最大匹配)

标签:

原文地址:http://www.cnblogs.com/program-ccc/p/5180666.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!