码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 3549 Flow Problem

时间:2014-07-24 17:50:06      阅读:231      评论:0      收藏:0      [点我收藏+]

标签:des   style   java   color   os   io   for   re   

Flow Problem

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 7250    Accepted Submission(s): 3364


Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 

Sample Input
2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
 

Sample Output
Case 1: 1 Case 2: 2
 

题意:n个节点,m条路径,其中给出每条路径的容量。求1到n的最大流

<span style="font-size:24px;">#include<stdio.h>
#include<algorithm>
#include<queue>
#define INF 1000
#define min(x,y) (x<y?x:y)
using namespace std;
int cap[20][20],flow[20][20],a[1000],p[100];
int n,m,f,s,t;

void Edmonds_Karp()
{
	queue<int> q;
	memset(flow,0,sizeof(flow));
	f=0;
	s=1;
	t=n;
	while(1)
	{
		memset(a,0,sizeof(a));
		a[s]=INF;
		q.push(s); 
		while(!q.empty())
		{
			int u=q.front();
			q.pop();
			for(int v=1;v<=n;v++)
			{
				if(!a[v]&&cap[u][v]>flow[u][v])
				{
					p[v]=u;
					q.push(v);
					a[v]=min(a[u],cap[u][v]-flow[u][v]);
				}
			}
		}
		if(a[t]==0) break;	
		for(int u=t;u!=s;u=p[u])
		{
			flow[p[u]][u]+=a[t];
			flow[u][p[u]]-=a[t];
		}
		f+=a[t];
	}
}

int main()
{
	int t,k=1;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d %d",&n,&m);
		memset(cap,0,sizeof(cap));
		for(int i=0;i<m;i++)
		{
			int x,y,c;
			scanf("%d %d %d",&x,&y,&c);
			cap[x][y]+=c;
		}
		Edmonds_Karp();
		printf("Case %d: %d\n",k++,f);
	}
	return 0;
}</span>


 

hdu 3549 Flow Problem,布布扣,bubuko.com

hdu 3549 Flow Problem

标签:des   style   java   color   os   io   for   re   

原文地址:http://blog.csdn.net/fyxz1314/article/details/38082443

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!