码迷,mamicode.com
首页 > 其他好文 > 详细

Duff and Weight Lifting_贪心

时间:2016-02-07 02:12:39      阅读:245      评论:0      收藏:0      [点我收藏+]

标签:

Duff and Weight Lifting

TimeLimit:1000MS  MemoryLimit:256MB
64-bit integer IO format:%I64d
Problem Description

Recently, Duff has been practicing weight lifting. As a hard practice, Malek gave her a task. He gave her a sequence of weights. Weight of i-th of them is 2wi pounds. In each step, Duff can lift some of the remaining weights and throw them away. She does this until there‘s no more weight left. Malek asked her to minimize the number of steps.

技术分享

Duff is a competitive programming fan. That‘s why in each step, she can only lift and throw away a sequence of weights 2a1, ..., 2ak if and only if there exists a non-negative integer x such that 2a1 + 2a2 + ... + 2ak = 2x, i. e. the sum of those numbers is a power of two.

Duff is a competitive programming fan, but not a programmer. That‘s why she asked for your help. Help her minimize the number of steps.

Input

The first line of input contains integer n (1 ≤ n ≤ 106), the number of weights.

The second line contains n integers w1, ..., wn separated by spaces (0 ≤ wi ≤ 106 for each 1 ≤ i ≤ n), the powers of two forming the weights values.

Output

Print the minimum number of steps in a single line.

SampleInput 1
5
1 1 2 3 3
SampleOutput 1
2
SampleInput 2
4
0 1 2 3
SampleOutput 2
4
Note

In the first sample case: One optimal way would be to throw away the first three in the first step and the rest in the second step. Also, it‘s not possible to do it in one step because their sum is not a power of two.

In the second sample case: The only optimal way is to throw away one weight in each step. It‘s not possible to do it in less than 4 steps because there‘s no subset of weights with more than one weight and sum equal to a power of two.

 

该题运用贪心。

若每次选取最小的有存在单数, 去除次数必 + 1, 其余累加到下一个去, 重复上述操作。

代码:

技术分享
#include <cstdio>
#include <cstring>
using namespace std;
const int all = 1000070;
int num[ all  ];
int n, cnt, tmp;
int main(void)
{
   scanf( "%d", &n );
   cnt = 0;
   while( n -- ){
      scanf( "%d", &tmp );
      ++ num[ tmp ];
   }

   for( int i=0; i < all; ++ i ){
// 若存在单数, +1
      cnt += ( num[i]&1 );
// 累加到下一行
      num[i+1] += ( num[i]/2 );
   }
   printf( "%d\n", cnt );

   return 0;
}
View Code

 

Duff and Weight Lifting_贪心

标签:

原文地址:http://www.cnblogs.com/seana/p/5184436.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!