码迷,mamicode.com
首页 > 其他好文 > 详细

Duff and Meat_贪心

时间:2016-02-07 02:13:32      阅读:252      评论:0      收藏:0      [点我收藏+]

标签:

Duff and Meat

TimeLimit:1000MS  MemoryLimit:256MB
64-bit integer IO format:%I64d
Problem Description

Duff is addicted to meat! Malek wants to keep her happy for n days. In order to be happy in i-th day, she needs to eat exactly ai kilograms of meat.

技术分享

There is a big shop uptown and Malek wants to buy meat for her from there. In i-th day, they sell meat for pi dollars per kilogram. Malek knows all numbers a1, ..., anand p1, ..., pn. In each day, he can buy arbitrary amount of meat, also he can keep some meat he has for the future.

Malek is a little tired from cooking meat, so he asked for your help. Help him to minimize the total money he spends to keep Duff happy for n days.

Input

The first line of input contains integer n (1 ≤ n ≤ 105), the number of days.

In the next n lines, i-th line contains two integers ai and pi (1 ≤ ai, pi ≤ 100), the amount of meat Duff needs and the cost of meat in that day.

Output

Print the minimum money needed to keep Duff happy for n days, in one line.

SampleInput 1
3
1 3
2 2
3 1
SampleOutput 1
10
SampleInput 2
3
1 3
2 1
3 2
SampleOutput 2
8
Note

In the first sample case: An optimal way would be to buy 1 kg on the first day, 2 kg on the second day and 3 kg on the third day.

In the second sample case: An optimal way would be to buy 1 kg on the first day and 5 kg (needed meat for the second and third day) on the second day.

 

 

按照题意,可以用现在的价钱买以后的东西, 每次选择最小价买就可以了。

代码:

技术分享
#include <cstdio>
#include <algorithm>
using namespace std;
typedef struct node Node;
const int all = (1e+5)+5;
struct node
{
   int p;
   int a;
};
Node num[ all ];

int main(void)
{
   int n, cnt = 0, p;
   scanf( "%d", &n );
   for( int i=0; i < n; ++ i ){
      scanf( "%d%d", &num[i].a, &num[i].p );
   }

// 初始化最小价
   p = num[0].p;
   for( int i=0; i < n; ++ i ){
      if( num[i].p <= p ){
         cnt += num[i].p*num[i].a;
// 获得最小价
         p = num[i].p;
      }
      else{
// 用最小价买
         cnt += num[i].a*p;
      }
   }
   printf( "%d\n", cnt );

   return 0;
}
View Code

 

Duff and Meat_贪心

标签:

原文地址:http://www.cnblogs.com/seana/p/5184423.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!