码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1240 Asteroids!(BFS)

时间:2016-02-07 17:30:11      阅读:216      评论:0      收藏:0      [点我收藏+]

标签:

题目链接

Problem Description
You‘re in space.
You want to get home.
There are asteroids.
You don‘t want to hit them.
 
Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 5 components:
Start line - A single line, "START N", where 1 <= N <= 10.
Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:
‘O‘ - (the letter "oh") Empty space
‘X‘ - (upper-case) Asteroid present
Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft‘s starting position. The coordinate values will be integers separated by individual spaces.
Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target‘s position. The coordinate values will be integers separated by individual spaces.
End line - A single line, "END"
The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.
The first coordinate in a set indicates the column. Left column = 0.
The second coordinate in a set indicates the row. Top row = 0.
The third coordinate in a set indicates the slice. First slice = 0.
Both the Starting Position and the Target Position will be in empty space.

Output
For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.

 
Sample Input
START 1
O
0 0 0
0 0 0
END
START 3
XXX
XXX
XXX
OOO
OOO
OOO
XXX
XXX
XXX
0 0 1
2 2 1
END
START 5
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
XXXXX
XXXXX
XXXXX
XXXXX
XXXXX
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
0 0 0
4 4 4
END
 
Sample Output
1 0
3 4
NO ROUTE
 
题解:
首先庆祝一下打破了这题提交4444次的记录==
技术分享?技术分享
言归正传,好长的input...看晕了。
好了,再次言归正传→_→,题意是给出一个N,然后给出任意数量包含N个‘X’或‘O’的行(前3*N行是有效行),以‘END’结尾,我还一直纳闷END有什么用。然后给两个坐标,分别是起点和终点。这个坐标要注意按顺序是列,行,维度(起始都是0),所以定义点坐标是x,y,z时,输入读取的顺序是z,y,x,否则第二个测试数据答案会是无解(说不清楚看代码)。
#include <cstdio>
#include <iostream>
#include <string>
#include <sstream>
#include <cstring>
#include <stack>
#include <queue>
#include <algorithm>
#include <cmath>
#include <map>
#define PI acos(-1.0)
#define ms(a) memset(a,0,sizeof(a))
#define msp memset(mp,0,sizeof(mp))
#define msv memset(vis,0,sizeof(vis))
using namespace std;
//#define LOCAL
int n,m;
struct Node
{
    int x,y,z;
    int step;
}sp,ep,cp;
char mp[12][12][12];
int dir[6][3]={{0,1,0},{0,-1,0},{-1,0,0},{1,0,0},{0,0,1},{0,0,-1}};
int bfs()
{
    queue<Node> q;
    while(!q.empty())q.pop();
    q.push(sp);
    while(!q.empty())
    {
        sp=q.front(),q.pop();
        if(sp.x==ep.x&&sp.y==ep.y&&sp.z==ep.z)return sp.step;
        for(int i=0;i<6;i++)
        {
            cp.x=sp.x+dir[i][0];
            cp.y=sp.y+dir[i][1];
            cp.z=sp.z+dir[i][2];
            cp.step=sp.step+1;
            if(mp[cp.x][cp.y][cp.z]==X)continue;
            if(cp.x<0||cp.y<0||cp.z<0||cp.x>=n||cp.y>=n||cp.z>=n)continue;
            mp[cp.x][cp.y][cp.z]=X;
            q.push(cp);
        }
    }
    return -1;
}
int main()
{
#ifdef LOCAL
    freopen("in.txt", "r", stdin);
#endif // LOCAL
    ios::sync_with_stdio(false);
    char t[10];
    while(cin>>t>>n)
    {
        m=0;
        for(int i=0;i<n;i++)
        for(int j=0;j<n;j++)
        cin>>mp[i][j];
        cin>>sp.z>>sp.y>>sp.x;//x-col,y-raw,z-dim
        cin>>ep.z>>ep.y>>ep.x;
        sp.step=0,ep.step=0;
        mp[sp.x][sp.y][sp.z]=X;
        int ans=bfs();
        if(ans==-1)printf("NO ROUTE\n");
        else printf("%d %d\n",n,ans);
        while(cin>>t)if(t[0]==E)break;
    }
    return 0;
}

 

HDU 1240 Asteroids!(BFS)

标签:

原文地址:http://www.cnblogs.com/gpsx/p/5184751.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!