码迷,mamicode.com
首页 > 其他好文 > 详细

POJ_1753——Flip Game(枚举)

时间:2016-02-09 12:01:42      阅读:284      评论:0      收藏:0      [点我收藏+]

标签:

Flip Game

Time Limit: 1000MS  Memory Limit: 65536K

 

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it‘s black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

技术分享Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it‘s impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

(1)最优解只与翻转棋子的位置有关,与翻转的次序无关;
(2)对于任一棋子,翻转奇数次等同于翻转一次,翻转偶数次等同与不翻转;
(3)当某一棋子确定时,若存在方案,则方案唯一。

思路:题解必然是对某一些棋子进行一次翻转,通过深搜分别枚举翻转次数为0、1、2···16时的情况,总的枚举情况有2^16=65536种。


ACcode:
技术分享
 #include<iostream>
using namespace std;
 
const int N = 4;
bool map[N][N],flag;
int step;
 
//判断全白或全黑
bool judge(){
    int i,j;
    for( i = 0; i < N; i++ )
        for( j = 0; j < N; j++ ){
            if( map[i][j] != **map )
                return false;
           }
    return true;
}
 
//翻转棋子
void flip(int i, int j){
    map[i][j] = !map[i][j];
    if( i > 0 )
        map[i-1][j] = !map[i-1][j];
    if( i < 3 )
        map[i+1][j] = !map[i+1][j];
    if( j > 0 )
        map[i][j-1] = !map[i][j-1];
    if( j < 3 )
        map[i][j+1] = !map[i][j+1];
 }
 
 
void dfs(int i, int j, int dp){
 
    if( dp == step ){
        flag = judge();
        return;
    }
 
    if( flag || i == N )
        return;
 
    flip(i,j);//翻转
    if( j < 3 )
        dfs(i,j+1,dp+1);
    else
        dfs(i+1,0,dp+1);
    flip(i,j);//还原
 
    if( j < 3 )
        dfs(i,j+1,dp);
    else
        dfs(i+1,0,dp);
}
 
int main(void){
    int i,j;
    char c;
 
    for( i = 0; i < N; i++ )
        for( j = 0; j < N; j++ ){
            cin >> c;
            if( c == b )
                map[i][j] = 1;
        }
 
    //枚举翻转次数
    for( step = 0; step <= 16; step++ ){
        dfs(0,0,0);
        if( flag ){
            cout << step <<endl;
            return 0;
        }
    }
 
    cout << "Impossible" <<endl;
    return 0;
}
View Code

测试数据:

bwbw
wwww
bbwb
bwwb
Impossible

bwwb
bbwb
bwwb
bwww
4

wwww
wwww
wwww
wwww
0

bbbb
bbbb
bbbb
bbbb
0

bbbb
bwbb
bbbb
bbbb
Impossible

bwbb
bwbb
bwbb
bbbb
Impossible

bwbb
wwwb
bwbb
bbbb
1

wwww
wwwb
wwbb
wwwb
1

wwww
wwww
wwwb
wwbb
1

wbwb
bwbw
wbwb
bwbw
Impossible

bbbb
bwwb
bwwb
bbbb
4

bwwb
wbbw
wbbw
bwwb
4

bbww
bbww
wwbb
wwbb
Impossible

bbwb
bbbw
wwbb
wwwb
Impossible

wwwb
wwbw
wbww
wwbw
Impossible

bbbb
wwww
wwbb
wbbb
Impossible

bwwb
wbwb
wbbb
wbbb
4

bwbb
bwbb
bwbw
bbbw
5

wbwb
bbbb
bbww
wbbb
6

bbwb
bbbb
wbwb
bbbb
5


POJ_1753——Flip Game(枚举)

标签:

原文地址:http://www.cnblogs.com/MrWhite083/p/5185474.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!