码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1081 To The Max

时间:2016-02-09 17:25:10      阅读:234      评论:0      收藏:0      [点我收藏+]

标签:

题目链接

Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 
Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 
Output
Output the sum of the maximal sub-rectangle.
 
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1
-1 8 0 -2
 
Sample Output
15

 题解:属于动态规划,不过可以暴力水过,列举所有可能找出最大和即可。

先求出前缀和,把数组变成第n列是前n列的和,这样不用每次列举的时候都求和。

然后两个for循环列举列,两个for循环列举行,具体还是看代码吧。

#include <cstdio>
#include <iostream>
#include <string>
#include <sstream>
#include <cstring>
#include <stack>
#include <queue>
#include <algorithm>
#include <cmath>
#include <map>
#define PI acos(-1.0)
#define ms(a) memset(a,0,sizeof(a))
#define msp memset(mp,0,sizeof(mp))
#define msv memset(vis,0,sizeof(vis))
using namespace std;
//#define LOCAL
int main()
{
#ifdef LOCAL
    freopen("in.txt", "r", stdin);
#endif // LOCAL
    ios::sync_with_stdio(false);
    int mp[120][120];
    int n;
    while(cin>>n)
    {msp;
    for(int i=0; i<n; i++)
    for(int j=0; j<n; j++)
    {
        cin>>mp[i][j];
        if(j!=0)mp[i][j]=mp[i][j]+mp[i][j-1];
    }
    int cnt=0,maxx=-1e9;
    for(int x1=0; x1<n; x1++)
    for(int x2=x1; x2<n; x2++)
    {
        for(int y1=0; y1<n; y1++)
        {cnt=0;
        for(int y2=y1; y2<n; y2++)
        {
            if(x1!=x2)cnt+=mp[y2][x2]-mp[y2][x1];
            else cnt+=mp[y2][x2];
            maxx=max(maxx,cnt);
        }}
    }
    printf("%d\n",maxx);}
    return 0;
}

 

HDU 1081 To The Max

标签:

原文地址:http://www.cnblogs.com/gpsx/p/5185613.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!