码迷,mamicode.com
首页 > 其他好文 > 详细

I - Long Distance Racing(第二季水)

时间:2016-02-11 23:48:36      阅读:267      评论:0      收藏:0      [点我收藏+]

标签:

Description

Bessie is training for her next race by running on a path that includes hills so that she will be prepared for any terrain. She has planned a straight path and wants to run as far as she can -- but she must be back to the farm within M seconds (1 ≤ M ≤ 10,000,000).

The entire path she has chosen is T units (1 ≤ T ≤ 100,000) in length and consists of equal-length portions that are uphill, flat, or downhill. The input data describes path segment i with a single character Si that is u, f, or d, indicating respectively uphill, flat, or downhill.

Bessie takes U seconds (1 ≤ U ≤ 100) to run one unit of uphill path, F (1 ≤ F ≤ 100) seconds for a unit of flat path, and D (1 ≤ D ≤ 100) seconds for a unit of downhill path. Note that, when returning home, uphill paths become downhill paths and downhill paths become uphill paths.

Find the farthest distance Bessie can get from the farm and still make it back in time.

Input

* Line 1: Five space-separated integers: M, T,U, F, and D * Lines 2..T+1: Line i+1 describes path segment i with a single letter: Si

Output

* Line 1: A single integer that is the farthest distance (number of units) that Bessie can get from the farm and make it back in time.

Sample Input

13 5 3 2 1
u
f
u
d
f

Sample Output

3

太水,不解释
#include<iostream>
using namespace std;
char s[100000];
int main()
{
    int m,t,u,f,d,k=0,a;
    cin>>m>>t>>u>>f>>d;
    for(int i=0;i<t;i++)cin>>s[i];
    int i;
    for(i=0;i<t;i++){
        if(s[i]==u||s[i]==d)k+=u+d;
        else k+=2*f;
        if(k>m)break;
        a=k;
    }
    cout<<i<<endl;
    //system("pause");
    return 0;
}

 

I - Long Distance Racing(第二季水)

标签:

原文地址:http://www.cnblogs.com/farewell-farewell/p/5186744.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!