码迷,mamicode.com
首页 > 其他好文 > 详细

POJ1742(多重部分和问题:模板题)

时间:2016-02-12 11:41:15      阅读:153      评论:0      收藏:0      [点我收藏+]

标签:

Coins
Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 32776   Accepted: 11131

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn‘t know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony‘s coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4
#include"cstdio"
#include"cstring"
using namespace std;
const int MAXN=100005;
int dp[MAXN];
int n,m;
int A[MAXN];
int C[MAXN];
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF&&(n||m))
    {
        memset(dp,-1,sizeof(dp));
        for(int i=0;i<n;i++)    scanf("%d",&A[i]);
        for(int i=0;i<n;i++)    scanf("%d",&C[i]);
        dp[0]=0;
        for(int i=0;i<n;i++)
            for(int j=0;j<=m;j++)
                if(dp[j]>=0)
                {
                    dp[j]=C[i];
                }
                else if(j<A[i]||dp[j-A[i]]<=0)
                {
                    dp[j]=-1;
                }
                else
                {
                    dp[j]=dp[j-A[i]]-1;
                }
        int ans=0;
        for(int i=1;i<=m;i++)
            if(dp[i]>=0)    ans++;
        printf("%d\n",ans);
    }
    
    return 0;
}

 

POJ1742(多重部分和问题:模板题)

标签:

原文地址:http://www.cnblogs.com/program-ccc/p/5186914.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!