码迷,mamicode.com
首页 > 其他好文 > 详细

水题一枚

时间:2014-05-07 09:56:16      阅读:310      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   code   java   

Description

Given a code (not optimized), and necessary inputs, you have to find the output of the code for the inputs. The code is as follows:

bubuko.com,布布扣
int a, b, c, d, e, f;
int fn( int n ) {
    if( n == 0 ) return a;
    if( n == 1 ) return b;
    if( n == 2 ) return c;
    if( n == 3 ) return d;
    if( n == 4 ) return e;
    if( n == 5 ) return f;
    return( fn(n-1) + fn(n-2) + fn(n-3) + fn(n-4) + fn(n-5) + fn(n-6) );
}
int main() {
    int n, caseno = 0, cases;
    scanf("%d", &cases);
    while( cases-- ) {
        scanf("%d %d %d %d %d %d %d", &a, &b, &c, &d, &e, &f, &n);
        printf("Case %d: %d\n", ++caseno, fn(n) % 10000007);
    }
    return 0;
}
bubuko.com,布布扣

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains seven integers, a, b, c, d, e, f and n. All integers will be non-negative and 0 ≤ n ≤ 10000 and the each of the others will be fit into a 32-bit integer.

 

Output

For each case, print the output of the given code. The given code may have integer overflow problem in the compiler, so be careful.

 

Sample Input

5

0 1 2 3 4 5 20

3 2 1 5 0 1 9

4 12 9 4 5 6 15

9 8 7 6 5 4 3

3 4 3 2 54 5 4

 

Sample Output

Case 1: 216339

Case 2: 79

Case 3: 16636

Case 4: 6

Case 5: 54

bubuko.com,布布扣
#include <stdio.h>
#include <string.h>
int a, b, c, d, e, f;
int m[10005];

int main() {
    int n, caseno = 0, cases;
    scanf("%d", &cases);
    int flag=1;
    while(cases--){
        scanf("%d %d %d %d %d %d %d", &a, &b, &c, &d, &e, &f, &n);
        m[0]=a;
        m[1]=b;
        m[2]=c;
        m[3]=d;
        m[4]=e;
        m[5]=f;
        for(int i=6;i<=n;i++)
            m[i]=m[i-1]% 10000007+m[i-2]% 10000007+m[i-3]% 10000007+m[i-4]% 10000007+m[i-5]% 10000007+m[i-6]% 10000007;
        printf("Case %d: %d\n", ++caseno,m[n]% 10000007);
    }
    return 0;
}
bubuko.com,布布扣

水题一枚,布布扣,bubuko.com

水题一枚

标签:des   style   blog   class   code   java   

原文地址:http://www.cnblogs.com/JT-L/p/3710269.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!