码迷,mamicode.com
首页 > 其他好文 > 详细

hdu2222Keywords Search (字典树)

时间:2014-07-24 23:22:23      阅读:256      评论:0      收藏:0      [点我收藏+]

标签:malloc   typedef   字典树   string   

Problem Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.

Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters ‘a‘-‘z‘, and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.

Output
Print how many keywords are contained in the description.

Sample Input
1 5 she he say shr her yasherhs

Sample Output
3
注意:在n个关键字中可以重复。在字符串中,前面出现的关键字后面就不能重加。

#include<stdio.h>
#include<malloc.h>
typedef struct nnn
{
    int flag;
    struct nnn *next[26];
}node;
node *builde()
{
    node *p=(node*)malloc(sizeof(node));
    p->flag=0;
    for(int i=0;i<26; i++)
    p->next[i]=NULL;
    return p;
}
node *root;
void insert(char str[])
{
    node *p=root;
    for(int i=0;str[i]!='\0';i++)
    {
        if(p->next[str[i]-'a']==NULL)
        p->next[str[i]-'a']=builde();
        p=p->next[str[i]-'a'];
    }
    p->flag++;
}
int count(char str[])
{
    int sum=0;
    for(int i=0;str[i]!='\0';i++)
    {
        node *p=root;
        for(int j=i;str[j]!='\0';j++)
        {
            if(p->next[str[j]-'a']==NULL)
                break;
            p=p->next[str[j]-'a'];
            sum+=p->flag; p->flag=0;
        }
    }
    return sum;
}
char str[1000005];
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        root=builde();
        while(n--)
        {
            scanf("%s",str);
            insert(str);
        }
        scanf("%s",str);
        printf("%d\n",count(str));
    }
}


hdu2222Keywords Search (字典树),布布扣,bubuko.com

hdu2222Keywords Search (字典树)

标签:malloc   typedef   字典树   string   

原文地址:http://blog.csdn.net/u010372095/article/details/38089723

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!